Skip to main content
VulnerabilityPublished

CVE-2026-61549: woodpecker · Improper Privilege Management

Affects woodpeckerSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 9.0 Critical : upgrade to 3.16.0 as a priority.

Data as of 30 Oct 2026, 20:25 UTC

CVSS 4.0 base score
9.0Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 20% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 3.16.0
CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 15 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade woodpecker to 3.16.0.

Affected software

ProductAffectedFixed in
woodpecker-ciwoodpeckerAffected
  • >=1.0.0 <3.16.0
Fixed in
  • 3.16.0
GitHubwoodpecker-ci/woodpeckerpkg:github/woodpecker-ci/woodpeckerOther threatsAffected
  • =316.0
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade woodpecker to version 3.16.0 or later, where this vulnerability is fixed. Until then, restrict Push permissions to trusted users only and review Kubernetes ServiceAccount permissions to minimize risk. No other official fixes or temporary mitigations are documented.

Description

Woodpecker CI/CD engine versions from 1.0.0 up to but not including 3.16.0 contain an improper privilege management vulnerability. The Kubernetes backend allows users with Push permission on a repository to specify an arbitrary ServiceAccount for pipeline pods without administrator authorization. This can lead to privilege escalation where an attacker may access sensitive secrets and potentially take over the Kubernetes cluster. The issue is fixed in version 3.16.0.

References

Community reviews

Loading reviews…