Skip to main content
VulnerabilityPublished

CVE-2026-61592: djust · Session Fixation

Affects djustSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 7.4 High : upgrade to 1.0.7 soon.

Data as of 31 Oct 2026, 20:20 UTC

CVSS 3.1 base score
7.4High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 32% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.0.7
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 16 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 31 Oct 2026.

What to do

Upgrade djust and djust-org/djust to 1.0.7.

Affected software

ProductAffectedFixed in
djust-orgdjustAffected
  • <1.0.7
Fixed in
  • 1.0.7
GitHubdjust-org/djustpkg:github/djust-org/djustOther threatsAffected
  • <1.0.7
Fixed in
  • 1.0.7

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade djust to version 1.0.7 or later, where the vulnerability is fixed by binding SSE sessions to the authenticated principal and rejecting cross-principal access. As a temporary workaround, disable the SSE transport to prevent exploitation.

Description

CVE-2026-61592 is a session fixation vulnerability in djust versions prior to 1.0.7. The issue arises because SSE sessions were keyed solely by a client-chosen session_id without binding to the authenticated user, allowing an attacker who obtains a valid session_id to impersonate the victim. This vulnerability is fixed in version 1.0.7 by binding SSE sessions to the owning principal and rejecting cross-principal access. A workaround is to disable the SSE transport.

References

Community reviews

Loading reviews…