Skip to main content
VulnerabilityPublished

CVE-2026-61599: djust · Unsafe Reflection

Affects djustSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 8.8 High : upgrade to 1.0.7 soon.

Data as of 31 Oct 2026, 20:20 UTC

CVSS 4.0 base score
8.8High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.6% chance of exploitation in 30 days – higher than 48% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.0.7
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:H/VA:L/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 16 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 31 Oct 2026.

What to do

Upgrade djust to 1.0.7.

Affected software

ProductAffectedFixed in
djust-orgdjustAffected
  • <1.0.7
Fixed in
  • 1.0.7
PyPIdjustpkg:pypi/djustOther threatsAffected
  • <1.0.7
Fixed in
  • 1.0.7

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade to djust version 1.0.7 or later, which implements a fail-closed import resolution gate preventing unsafe imports from untrusted clients. As a workaround prior to upgrading, configure the LIVEVIEW_ALLOWED_MODULES setting to a narrow, explicit list of modules containing mountable LiveView classes to reduce the attack surface. Note that this workaround is not a complete fix because the import still occurs before subclass checks. No other mitigations are indicated.

Description

CVE-2026-61599 is a high-severity vulnerability in djust versions prior to 1.0.7 that allows unauthenticated WebSocket clients to cause the server to import and execute arbitrary Python modules. This occurs because the live transport resolves LiveView classes from client-supplied module paths using __import__ before validating the class or performing authentication. The default allowlist for permitted modules is fail-open and uses loose matching, enabling unsafe reflection and code execution. Version 1.0.7 introduces a fail-closed check that restricts imports to already loaded modules or explicitly allowed modules, preventing this unsafe behavior.

References

Community reviews

Loading reviews…