Skip to main content
VulnerabilityPublished

CVE-2026-61620: seancorfield honeysql · SQL Injection

Affects seancorfield honeysqlSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 9.8 Critical : upgrade to 2.7.1392 as a priority.

Data as of 30 Oct 2026, 20:18 UTC

CVSS 3.1 base score
9.8Critical
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (GitHub_M)CVSS 3.19.8
Patch
Available – fixed in 2.7.1392
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 30 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade seancorfield honeysql to 2.7.1392.

Affected software

ProductAffectedFixed in
seancorfieldhoneysqlAffected
  • >=2.0.0 <2.7.1392
Fixed in
  • 2.7.1392

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade HoneySQL to version 2.7.1392 or later, where this vulnerability is fixed. Until upgrading, ensure strict input validation before passing data to keyword or symbol functions in HoneySQL to prevent injection. No other vendor advisories indicate alternative mitigations or that no action is required.

Description

CVE-2026-61620 is a critical SQL injection vulnerability in the HoneySQL library versions from 2.0.0 up to but not including 2.7.1392. The issue arises when user input or arbitrary data is passed into HoneySQL's DSL via calls to keyword or symbol without proper validation, potentially producing SQL strings that facilitate injection attacks. The vulnerability depends on the privileges of the database connection executing the generated SQL. The flaw is fixed in version 2.7.1392.

References

Community reviews

Loading reviews…