Skip to main content
VulnerabilityPublished

CVE-2026-61687: hatchet · Improper Authentication

Affects hatchetSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 7.1 High : upgrade to 0.91.1 soon.

Data as of 5 Nov 2026, 00:01 UTC

CVSS 3.1 base score
7.1High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 6% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 0.91.1
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 21 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Upgrade hatchet and hatchet-dev/hatchet to 0.91.1.

Affected software

ProductAffectedFixed in
hatchet-devhatchetAffected
  • <0.91.1
Fixed in
  • 0.91.1
GitHubhatchet-dev/hatchetpkg:github/hatchet-dev/hatchetOther threatsAffected
  • <0.91.1
Fixed in
  • 0.91.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade Hatchet to version 0.91.1 or later, where this vulnerability is fixed. No other mitigation is indicated or required.

Description

Hatchet is a platform for orchestrating background tasks, AI agents, and durable workflows at scale. Prior to 0.91.1, ValidateOAuthState clears the oauth_state_ session value to an empty string after a successful OAuth callback and later accepts an empty state parameter as equal, allowing an unauthenticated attacker to bind a victim's Hatchet session to an attacker-controlled OAuth identity. Exploitation requires the victim to have completed an OAuth flow in the current session and the deployment to enable auth.google.enabled, auth.github.enabled, or the Slack integration. This issue is fixed in version 0.91.1.

References

Community reviews

Loading reviews…