Skip to main content
VulnerabilityPublished

CVE-2026-6216: DbGate · Cross-site Scripting

Affects DbGateSource CVE Database V5

0
Compare

Public exploit available · CVSS 5.1 Medium · fixed in 7.1.5 : patch DbGate as a priority.

Data as of 29 Oct 2026, 19:04 UTC

CVSS 4.0 base score
5.1Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 8% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 7.1.5
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N/E:P

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 13 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: evidence found.

    CVSS exploit maturity: proof of concept public

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), CVSS vector, the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
DbGateAffected
  • 7.1.0 – 7.1.4
5 affected builds
Fixed in–
GitHubdbgate/dbgatepkg:github/dbgate/dbgateOther threatsAffected
  • 7.1.0 – 7.1.4
5 affected builds
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade the affected DbGate component to version 7.1.5, which mitigates this cross-site scripting vulnerability. Since the vendor has provided an official fix, applying this update is the recommended remediation. No additional mitigation steps are indicated.

Description

CVE-2026-6216 is a medium severity cross-site scripting (XSS) vulnerability in DbGate versions up to 7.1.4. It arises from improper handling of the applicationIcon argument in the SVG Icon String Handler component, specifically in the file packages/web/src/icons/FontIcon.svelte. This vulnerability can be exploited remotely and has been publicly disclosed. Upgrading to DbGate version 7.1.5 mitigates the issue.

References

Community reviews

Loading reviews…