Skip to main content
VulnerabilityPublished Updated

CVE-2026-62280: OpenIdentityPlatform OpenAM · Cross-site Scripting

Affects OpenIdentityPlatform OpenAMSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 6.1 Medium : upgrade to 16.1.2 when convenient.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
6.1Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 25% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 16.1.2
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 15 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade OpenAM and openidentityplatform/OpenAM to 16.1.2.

Affected software

ProductAffectedFixed in
OpenIdentityPlatformOpenAMAffected
  • >=13.0.0 <16.1.2
Fixed in
  • 16.1.2
GitHubopenidentityplatform/OpenAMpkg:github/openidentityplatform/OpenAMOther threatsAffected
  • >=13.0.0 <16.1.2
Fixed in
  • 16.1.2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade OpenAM to version 16.1.2 or later, where this vulnerability is fixed. No other mitigations are specified. Patch status is confirmed fixed in 16.1.2.

Description

Open Access Management (OpenAM) is an access management solution. From 13.0.0 until 16.1.2, the OAuth2 authorize endpoint's display=wap consent page reflects request-derived values through ConsentRequiredResource and wap/authorize.ftl without HTML escaping. An attacker can induce a user with an active OpenAM session to follow a crafted authorization link and execute JavaScript in the OpenAM origin, enabling session or cookie theft, CSRF-token disclosure, and actions with the victim's privileges. At least one registered OAuth2 client is required, but the attacker does not need to control that client. This issue is fixed in version 16.1.2.

References

Community reviews

Loading reviews…