CVE-2026-62857: fedify · Server-Side Request Forgery (SSRF)
Affects fedifySource CVE Database V5
Not known to be exploited · CVSS 8.8 High · fixed in 2.3.2 : patch fedify soon.
Data as of 5 Nov 2026, 00:01 UTC
- EPSS
- 0.4% chance of exploitation in 30 days – higher than 36% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.3.2, 2.2.7, 2.1.18 +3
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:L/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 6 Aug 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.
What to do
Upgrade to a fixed release listed under Affected software.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| fedify-devfedify | Affected
| Fixed in
|
| fedify-devfedify | Affected
| Fixed in
|
| fedify-devfedify | Affected
| Fixed in
|
| fedify-devfedify | Affected
| Fixed in
|
| fedify-devfedify | Affected
| Fixed in
|
| fedify-devfedify | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
This vulnerability is fixed in fedify versions 1.9.13, 1.10.12, 2.0.22, 2.1.18, 2.2.7, and 2.3.2. Users should upgrade to these or later versions to remediate the issue. No official remediation level or temporary fixes are indicated beyond upgrading. Patch status is confirmed by the vendor advisory information embedded in the description.
Description
CVE-2026-62857 is a Server-Side Request Forgery (SSRF) vulnerability in the fedify TypeScript library used for building federated server apps powered by ActivityPub. Versions from 1.2.0 up to but not including 1.9.13, 1.10.12, 2.0.22, 2.1.18, 2.2.7, and 2.3.2 are affected. The vulnerability arises because the getNodeInfo() function follows attacker-controlled links[].href values from /.well-known/nodeinfo without validating the scheme, redirects, or private addresses. This allows an attacker to make requests to internal network services such as loopback, link-local, cloud metadata, and private network endpoints and receive their response bodies. The issue is fixed in the specified patched versions.