CVE-2026-62866: TomWright dasel · Improper Validation of Array Index
Affects TomWright daselSource CVE Database V5
Not known to be exploited · CVSS 6.2 Medium : upgrade to 3.11.2 when convenient.
Data as of 5 Nov 2026, 23:24 UTC
- EPSS
- 0.1% chance of exploitation in 30 days – higher than 8% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 3.11.2
CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 21 Sep 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.
What to do
Upgrade TomWright dasel to 3.11.2.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| TomWrightdasel | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade dasel to version 3.11.2 or later, where this issue is fixed. No other mitigations are indicated.
Description
CVE-2026-62866 is a medium severity vulnerability in TomWright's dasel command-line tool and library. Versions from 3.0.0 up to but not including 3.11.2 contain an improper validation of array index in the parseCurRune function. This flaw can cause an index-out-of-range panic when processing selectors ending with whitespace, leading to process termination. The issue is fixed in version 3.11.2.