Skip to main content
VulnerabilityPublished

CVE-2026-62991: shopperlabs shopper · Insecure Direct Object Reference

Affects shopperlabs shopperSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 6.5 Medium : upgrade to 2.10.1 when convenient.

Data as of 30 Oct 2026, 21:36 UTC

CVSS 3.1 base score
6.5Medium
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (GitHub_M)CVSS 3.16.5
Patch
Available – fixed in 2.10.1
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 30 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade shopper and shopperlabs/shopper to 2.10.1.

Affected software

ProductAffectedFixed in
shopperlabsshopperAffected
  • <2.10.1
Fixed in
  • 2.10.1
GitHubshopperlabs/shopperpkg:github/shopperlabs/shopperOther threatsAffected
  • <2.10.1
Fixed in
  • 2.10.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade to shopper version 2.10.1 or later, where this authorization bypass vulnerability is fixed. No additional mitigations are required once the update is applied.

Description

CVE-2026-62991 is an authorization bypass vulnerability in shopperlabs shopper prior to version 2.10.1. It allows authenticated staff with certain permissions to access and enumerate user profiles beyond their intended scope, including administrator and staff accounts. The flaw also permits destructive actions on non-customer accounts if additional privileges are held. This issue is fixed in version 2.10.1.

References

Community reviews

Loading reviews…