CVE-2026-63183: omniauth · Origin Validation Error
Affects omniauthSource CVE Database V5
Not known to be exploited · CVSS 6.9 Medium : upgrade to 2.2.0 when convenient.
Data as of 4 Nov 2026, 21:42 UTC
Thin evidence
One scorer or none| CNA (GitHub_M) | CVSS 4.0 | 6.9 |
|---|
- Patch
- Available – fixed in 2.2.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:N/SC:N/SI:L/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 4 Nov 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.
What to do
Upgrade omniauth to 2.2.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| omniauthomniauth | Affected
| Fixed in
|
RubyGemsomniauthpkg:gem/omniauthOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade OmniAuth to version 2.2.0 or later where this vulnerability is fixed. Alternatively, ensure that the application uses a fixed full_host configuration or framework-level incoming host validation such as Rails host authorization to prevent exploitation. No other mitigation is indicated by the vendor advisory.
Description
OmniAuth versions prior to 2.2.0 have an origin validation error that allows remote unauthenticated clients to supply a forged Host header. This can lead to host header injection risks in applications that do not have fixed full_host configurations or framework-level host validation, such as Rails host authorization. The issue is resolved in OmniAuth version 2.2.0.