Skip to main content
VulnerabilityPublished

CVE-2026-63203: logto · Missing Authorization

Affects logtoSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 7.6 High : upgrade to 1.42.0 soon.

Data as of 7 Nov 2026, 23:24 UTC

CVSS 3.1 base score
7.6High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 24% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.42.0
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 24 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 7 Nov 2026.

What to do

Upgrade logto and logto-io/logto to 1.42.0.

Affected software

ProductAffectedFixed in
logto-iologtoAffected
  • >=1.31.0 <1.42.0
Fixed in
  • 1.42.0
GitHublogto-io/logtopkg:github/logto-io/logtoOther threatsAffected
  • >=1.31.0 <1.42.0
Fixed in
  • 1.42.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade to logto version 1.42.0 or later where this issue is fixed. No other mitigations are indicated. Patch status is confirmed fixed in 1.42.0.

Description

Logto is the modern, open-source auth infrastructure for SaaS and AI apps. From 1.31.0 until 1.42.0, the Account API handlers in packages/core/src/routes/account/third-party-tokens.ts allow a caller holding a same-user access token with only the openid scope to retrieve stored social or enterprise SSO provider access tokens through GET /api/my-account/identities/{target}/access-token or GET /api/my-account/sso-identities/{connectorId}/access-token. The handlers authenticate the user but do not require the identities scope that protects neighboring identity-detail operations, bypassing the intended Account API consent boundary. Exploitation requires federated token-set storage to be enabled and the affected user to have authenticated through a supported connector. A low-trust application can use the disclosed provider token against upstream APIs within that token's granted scopes. This issue is fixed in version 1.42.0.

References

Community reviews

Loading reviews…