CVE-2026-63402: i18next · Modification of Assumed-Immutable Data (MAID)
Affects i18nextSource CVE Database V5
Not known to be exploited · CVSS 5.9 Medium : upgrade to 26.3.4 when convenient.
Data as of 30 Oct 2026, 23:06 UTC
Thin evidence
One scorer or none| CNA (GitHub_M) | CVSS 3.1 | 5.9 |
|---|
- Patch
- Available – fixed in 26.3.4
CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:N/I:L/A:HExploitation evidence
Disclosed: evidence found.
CVE published 30 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade i18next to 26.3.4.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| i18nexti18next | Affected
| Fixed in
|
npmi18nextpkg:npm/i18nextOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade i18next to version 26.3.4 or later, where this vulnerability is fixed. Applications not using `addResourceBundle` with both `deep: true` and `overwrite: true` are not vulnerable. No additional mitigation is required if the vulnerable configuration is not used. Since this is a library, ensure that all dependencies using i18next are also updated accordingly.
Description
CVE-2026-63402 is a vulnerability in the i18next JavaScript internationalization framework prior to version 26.3.4. It involves the `deepExtend` function improperly recursing into inherited built-in objects via the `in` operator, allowing an attacker to overwrite properties of shared built-in functions process-wide when specific parameters are used. This can cause unrecoverable denial of service by making functions like `hasOwnProperty` non-callable. The issue is fixed in version 26.3.4.