Skip to main content
VulnerabilityPublished

CVE-2026-63438: Bubka 2FAuth · Improper Authentication

Affects Bubka 2FAuthSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 9.8 Critical : upgrade to 8.0.0 as a priority.

Data as of 6 Nov 2026, 21:02 UTC

CVSS 3.1 base score
9.8Critical
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (GitHub_M)CVSS 3.19.8
Patch
Available – fixed in 8.0.0
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 6 Nov 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 6 Nov 2026.

What to do

Upgrade 2FAuth and bubka/2FAuth to 8.0.0.

Affected software

ProductAffectedFixed in
Bubka2FAuthAffected
  • <8.0.0
Fixed in
  • 8.0.0
GitHubbubka/2FAuthpkg:github/bubka/2FAuthOther threatsAffected
  • <8.0.0
Fixed in
  • 8.0.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade Bubka 2FAuth to version 8.0.0 or later, where this improper authentication vulnerability is fixed. No other mitigations are indicated by the vendor advisory. Users should apply this official fix promptly to prevent unauthorized administrative access and exposure of 2FA secrets.

Description

CVE-2026-63438 is a critical improper authentication vulnerability in Bubka's 2FAuth web application prior to version 8.0.0. When configured with AUTHENTICATION_GUARD=reverse-proxy-guard, the application incorrectly accepts authentication headers from clients not passing through a trusted proxy. This flaw allows unauthenticated remote clients to create administrator accounts on fresh instances or impersonate existing users by synchronizing email headers, exposing two-factor authentication secrets and administrative functions. The issue is resolved in version 8.0.0.

References

Community reviews

Loading reviews…