Skip to main content
VulnerabilityPublished

CVE-2026-6350: Openfind MailGates · Stack-based Buffer Overflow

Affects Openfind MailGatesSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 9.3 Critical : upgrade to 6.1.10.054 or 5.2.10.099 as a priority.

Data as of 30 Oct 2026, 06:59 UTC

CVSS 4.0 base score
9.3Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.7% chance of exploitation in 30 days – higher than 55% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 6.1.10.054, 5.2.10.099
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 16 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade MailGates and MailAudit to 6.1.10.054 or 5.2.10.099.

Affected software

ProductAffectedFixed in
OpenfindMailGatesAffected
  • >=6.0 <6.1.10.054
Fixed in
  • 6.1.10.054
OpenfindMailGatesAffected
  • >=5.0 <5.2.10.099
Fixed in
  • 5.2.10.099
OpenfindMailAuditAffected
  • >=6.0 <6.1.10.054
Fixed in
  • 6.1.10.054
OpenfindMailAuditAffected
  • >=5.0 <5.2.10.099
Fixed in
  • 5.2.10.099

AI-suggested

If you cannot patch yet, organizations should consider applying workarounds if available, restrict network access to the MailGates service, and monitor for unusual activity related to this vulnerability. Avoid exposing affected versions directly to untrusted networks.

Description

MailGates/MailAudit developed by Openfind has a Stack-based Buffer Overflow vulnerability, allowing unauthenticated remote attackers to control the program's execution flow and execute arbitrary code.

References

Community reviews

Loading reviews…