CVE-2026-63501: Agamnentzar ag-psd · Unthrottled Resource Allocation
Affects Agamnentzar ag-psdSource CVE Database V5
Not known to be exploited · CVSS 7.5 High : upgrade to 31.0.1 soon.
Data as of 3 Nov 2026, 19:58 UTC
Thin evidence
One scorer or none| CNA (GitHub_M) | CVSS 3.1 | 7.5 |
|---|
- Patch
- Available – fixed in 31.0.1
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 3 Nov 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 3 Nov 2026.
What to do
Upgrade Agamnentzar ag-psd to 31.0.1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Agamnentzarag-psd | Affected
| Fixed in
|
npmag-psdpkg:npm/ag-psdOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade ag-psd to version 31.0.1 or later, where this vulnerability is fixed. No other mitigation is required as the fix addresses the improper memory limit handling and unbounded decompression.
Description
CVE-2026-63501 affects the ag-psd JavaScript library used for reading and writing Photoshop Document files. Versions prior to 31.0.1 improperly handle memory limits during PSD layer decoding and ZIP decompression, allowing attackers to cause excessive memory allocation. This can lead to process memory exhaustion and denial of service. The issue is fixed in version 31.0.1.