Skip to main content
CVE-2026-6365VulnerabilityPublished

CVE-2026-6365: Drupal core · "Cross-site Scripting"

Affects Drupal coreSource CVE Database V5

0

Not known to be exploited · CVSS 6.1 Medium · fixed in 11.3.7 : update Drupal core when convenient.

Data as of 25 Oct 2026, 19:02 UTC

CVSS 3.1 base score
6.1Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 12% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 11.3.7, 11.2.11, 10.6.7 +1
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 19 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.

What to do

Upgrade Drupal core and drupal/core to 11.3.7, 11.2.11, 10.6.7 or 10.5.9.

Affected software

ProductAffectedFixed in
DrupalDrupal coreAffected
  • >=8.0.0 <10.5.9
  • >=10.6.0 <10.6.7
  • >=11.0.0 <11.2.11
  • >=11.3.0 <11.3.7
Fixed in
  • 11.3.7
  • 11.2.11
  • 10.6.7
  • 10.5.9
Packagistdrupal/corepkg:composer/drupal/coreOther threatsAffected
  • =8.0.0
  • <10.5.9
  • >=10.6.0
  • <10.6.7
  • >=11.0.0
  • <11.2.11
  • >=11.3.0
  • <11.3.7
Fixed in
  • 10.5.9
  • 10.6.7
  • 11.2.11
  • 11.3.7

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

If you cannot patch yet, consider restricting user input or employing web application firewalls that can detect and block XSS attempts specific to Drupal.

Description

Improper Neutralization of Input During Web Page Generation ("Cross-site Scripting") vulnerability in Drupal Drupal core allows Cross-Site Scripting (XSS). This issue affects Drupal core: from 8.0.0 before 10.5.9, from 10.6.0 before 10.6.7, from 11.0.0 before 11.2.11, from 11.3.0 before 11.3.7.

References

Community reviews

Loading reviews…