CVE-2026-63734: surrealdb · Improper Input Validation
Affects surrealdbSource GCVE Database
Not known to be exploited · CVSS 6.9 Medium : upgrade to 3.2.0 when convenient.
Data as of 26 Oct 2026, 16:39 UTC
- EPSS
- 0.4% chance of exploitation in 30 days – higher than 40% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 3.2.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 20 Jul 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade surrealdb to 3.2.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| surrealdb surrealdb | Affected
| Fixed in
|
AI-suggested
Users should upgrade to SurrealDB version 3.2.0 or later once available, as the vulnerability affects versions before 3.2.0. If you cannot patch yet, restrict Owner-role access to trusted users only and avoid uploading untrusted or malformed .surml files to the /ml/import endpoint to prevent triggering the denial of service.
Description
SurrealDB versions before 3.2.0 have a denial of service vulnerability in the SurrealML header parser. Authenticated users with Owner role can crash the server by uploading a malformed .surml file to the /ml/import endpoint. The vulnerability arises from improper input validation, where non-numeric input-dimensions or malformed header fields cause unchecked unwrap calls that panic and abort the server process, resulting in denial of service.