CVE-2026-63888: Linux kernel · scsi: target: iscsi: Fix CRC overread and double-free in iscsit_handle_text_cmd()
Affects Linux kernelSource GCVE Database
Not known to be exploited · CVSS 9.8 Critical · fixed in 5.15.0-1116.123~20.04.1 : patch Linux kernel as a priority.
Data as of 28 Oct 2026, 12:27 UTC
- Patch
- Available – fixed in 5.15.0-1116.123~20.04.1, 5.15.0-1122.131~20.04.1, 5.15.0-1121.130~20.04.1 +74
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 19 Jul 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade to a fixed release listed under Affected software.
Patches and advisories
- ubuntu.com/security/notices/USN-8593-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8603-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8618-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8663-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8664-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8728-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8781-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8728-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-8817-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8818-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8818-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-8842-1 (opens in a new tab)
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 26.04 LTSlinuxpkg:deb/ubuntu/linux?arch=source&distro=resoluteOther threats | Affected
| Fixed in
|
Ubuntu 26.04 LTSlinux-awspkg:deb/ubuntu/linux-aws?arch=source&distro=resoluteOther threats | Affected
| Fixed in
|
Ubuntu 26.04 LTSlinux-azurepkg:deb/ubuntu/linux-azure?arch=source&distro=resoluteOther threats | Affected
| Fixed in
|
Ubuntu 26.04 LTSlinux-azure-fdepkg:deb/ubuntu/linux-azure-fde?arch=source&distro=resoluteOther threats | Affected
| Fixed in
|
Ubuntu 26.04 LTSlinux-gcppkg:deb/ubuntu/linux-gcp?arch=source&distro=resoluteOther threats | Affected
| Fixed in
|
Ubuntu 26.04 LTSlinux-gkepkg:deb/ubuntu/linux-gke?arch=source&distro=resoluteOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available and has been applied in Linux kernel versions 5.15.0-1116.123~20.04.1 and later. Users should update to these fixed kernel versions or later to remediate the vulnerability. No additional mitigation is required as the fix addresses both the buffer overread and double-free issues directly.
Description
CVE-2026-63888 is a critical vulnerability in the Linux kernel's iSCSI target implementation. It involves two latent bugs in the Text-phase handler: a buffer overread of 4 bytes during CRC calculation and a double-free condition on error recovery. These bugs can cause kernel memory corruption and crashes. The issue affects multiple Linux kernel versions and has been fixed in several 5.15.x releases. The vulnerability has a high CVSS score of 9.8 and no known exploits in the wild as of the publication date.
References
- ubuntu.com/security/CVE-2026-63888 (opens in a new tab)
- cve.org/CVERecord?id=CVE-2026-63888 (opens in a new tab)
- git.kernel.org/linus/778c2ab142c625a8a8afa570e0f9b7873f445d99 (opens in a new tab)
- ubuntu.com/security/notices/USN-8593-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8603-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8618-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8663-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8664-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8728-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8781-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8728-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-8817-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8818-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8818-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-8842-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8728-3 (opens in a new tab)
- ubuntu.com/security/notices/USN-8818-3 (opens in a new tab)
- ubuntu.com/security/notices/USN-8818-4 (opens in a new tab)
- ubuntu.com/security/notices/USN-8817-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-8849-1 (opens in a new tab)