CVE-2026-63902: Linux kernel · USB: serial: cypress_m8: validate interrupt packet headers
Affects Linux kernelSource GCVE Database
Not known to be exploited · fixed in 5.15.0-1117.124~20.04.1 : update Linux kernel when convenient.
Data as of 26 Oct 2026, 12:55 UTC
Rated by Threat Radar · No CVSS score from NVD or the CNA
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 13% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 5.15.0-1117.124~20.04.1, 5.15.0-1123.132~20.04.1, 5.15.0-1122.131~20.04.1 +65
Exploitation evidence
Disclosed: evidence found.
CVE published 20 Jul 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade to a fixed release listed under Affected software.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 26.04 LTSlinuxpkg:deb/ubuntu/linux?arch=source&distro=resoluteOther threats | Affected
| Fixed in
|
Ubuntu 26.04 LTSlinux-awspkg:deb/ubuntu/linux-aws?arch=source&distro=resoluteOther threats | Affected
| Fixed in
|
Ubuntu 26.04 LTSlinux-azurepkg:deb/ubuntu/linux-azure?arch=source&distro=resoluteOther threats | Affected
| Fixed in
|
Ubuntu 26.04 LTSlinux-azure-fdepkg:deb/ubuntu/linux-azure-fde?arch=source&distro=resoluteOther threats | Affected
| Fixed in
|
Ubuntu 26.04 LTSlinux-gcppkg:deb/ubuntu/linux-gcp?arch=source&distro=resoluteOther threats | Affected
| Fixed in
|
Ubuntu 26.04 LTSlinux-gkepkg:deb/ubuntu/linux-gke?arch=source&distro=resoluteOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available and included in standard Linux kernel updates. Users should apply the latest Linux kernel updates to remediate this vulnerability. No additional mitigation steps are required beyond applying the official fix.
Description
A vulnerability in the Linux kernel's USB serial driver for Cypress M8 devices allowed improper validation of interrupt packet headers, leading to potential out-of-bounds reads. The issue was fixed by ignoring malformed short reports and resubmitting the interrupt URB, preventing memory corruption. This affects multiple Linux kernel versions prior to 7.0.0-28.28 and related builds. A patch is available and included in standard Linux kernel updates.
References
- nvd.nist.gov/vuln/detail/CVE-2026-63902 (opens in a new tab)
- git.kernel.org/stable/c/44f9bab8df7750a1e2a4d6cc22d7c9c2dc096aed (opens in a new tab)
- git.kernel.org/stable/c/4a4cb0021ebe1fcadb52e04d19ed8d71470a530b (opens in a new tab)
- git.kernel.org/stable/c/90664556916de22467097d4c8ceb716d597a5c32 (opens in a new tab)
- git.kernel.org/stable/c/9f9bfc80c67f35a275820da7e83a35dface08281 (opens in a new tab)
- git.kernel.org/stable/c/aaa66708bfb1dca2acd219d1c1582f9f6d5492cb (opens in a new tab)
- git.kernel.org/stable/c/ae03453f2c809ca3cf73753269fa6184dea7160f (opens in a new tab)
- git.kernel.org/stable/c/be50533fe7068e86eb7adb81988e6d6a3f6dfe53 (opens in a new tab)
- git.kernel.org/stable/c/fcef31a5a85ccf3c313449a866ec6ed7e4132425 (opens in a new tab)
- ubuntu.com/security/CVE-2026-63902 (opens in a new tab)
- cve.org/CVERecord?id=CVE-2026-63902 (opens in a new tab)
- git.kernel.org/linus/9f9bfc80c67f35a275820da7e83a35dface08281 (opens in a new tab)
- ubuntu.com/security/notices/USN-8593-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8603-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8618-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8663-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8664-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8728-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8728-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-8728-3 (opens in a new tab)
- ubuntu.com/security/notices/USN-8878-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8879-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8877-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8875-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8903-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8905-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8906-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8904-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8903-2 (opens in a new tab)