CVE-2026-63915: Linux kernel · nfc: hci: fix out-of-bounds read in HCP header parsing
Affects Linux kernelSource GCVE Database
Not known to be exploited · CVSS 8.8 High · fixed in 5.15.0-1117.124~20.04.1 : patch Linux kernel soon.
Data as of 26 Oct 2026, 14:05 UTC
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 28% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 5.15.0-1117.124~20.04.1, 5.15.0-1123.132~20.04.1, 5.15.0-1122.131~20.04.1 +66
CVSS:3.1/AV:A/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 20 Jul 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade to a fixed release listed under Affected software.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 26.04 LTSlinuxpkg:deb/ubuntu/linux?arch=source&distro=resoluteOther threats | Affected
| Fixed in
|
Ubuntu 26.04 LTSlinux-awspkg:deb/ubuntu/linux-aws?arch=source&distro=resoluteOther threats | Affected
| Fixed in
|
Ubuntu 26.04 LTSlinux-azurepkg:deb/ubuntu/linux-azure?arch=source&distro=resoluteOther threats | Affected
| Fixed in
|
Ubuntu 26.04 LTSlinux-azure-fdepkg:deb/ubuntu/linux-azure-fde?arch=source&distro=resoluteOther threats | Affected
| Fixed in
|
Ubuntu 26.04 LTSlinux-gcppkg:deb/ubuntu/linux-gcp?arch=source&distro=resoluteOther threats | Affected
| Fixed in
|
Ubuntu 26.04 LTSlinux-gkepkg:deb/ubuntu/linux-gke?arch=source&distro=resoluteOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available and included in recent Ubuntu kernel updates. Users should apply the official kernel updates provided by their Linux distribution to remediate this vulnerability. No additional mitigation steps are required beyond applying the official fix.
Description
A high-severity vulnerability in the Linux kernel NFC subsystem involving out-of-bounds reads during HCP header parsing has been fixed. The flaw allowed a malicious NFC peer to send crafted zero-byte frames that triggered out-of-bounds heap reads and potential kernel panics. This issue affects multiple Linux kernel versions prior to 7.0.0-28.28~24.04.1 and related builds. A patch addressing the vulnerability is available and included in recent Ubuntu kernel updates.
References
- nvd.nist.gov/vuln/detail/CVE-2026-63915 (opens in a new tab)
- git.kernel.org/stable/c/1905f5ec3641b2b234bb63549c8ca11ab85466eb (opens in a new tab)
- git.kernel.org/stable/c/22d41b176b9989efd21c3b2d3abf6728f05b9d9a (opens in a new tab)
- git.kernel.org/stable/c/37382293f174b82a0616c8295e32b1fc8e13d1ed (opens in a new tab)
- git.kernel.org/stable/c/83b1362edc9d6ae376c6f36da116e2c70f2e70a6 (opens in a new tab)
- git.kernel.org/stable/c/b99366d74b535d0cadb1ef73e04639415d9ff3b7 (opens in a new tab)
- git.kernel.org/stable/c/c4cc6b3b0013acb3ed0b2b60e57dfae98647fe98 (opens in a new tab)
- git.kernel.org/stable/c/ed6d5d97dad0334a7f43d218753429cbe2f70a4f (opens in a new tab)
- git.kernel.org/stable/c/f040e590c035bfd9553fe79ee9585caf1b14d67b (opens in a new tab)
- ubuntu.com/security/CVE-2026-63915 (opens in a new tab)
- cve.org/CVERecord?id=CVE-2026-63915 (opens in a new tab)
- git.kernel.org/linus/f040e590c035bfd9553fe79ee9585caf1b14d67b (opens in a new tab)
- ubuntu.com/security/notices/USN-8593-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8603-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8618-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8663-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8664-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8728-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8781-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8728-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-8728-3 (opens in a new tab)
- ubuntu.com/security/notices/USN-8878-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8879-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8877-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8875-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8903-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8905-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8906-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8904-1 (opens in a new tab)