CVE-2026-63921: Linux kernel · ip6: vti: Use ip6_tnl.net in vti6_siocdevprivate().
Affects Linux kernelSource GCVE Database
Not known to be exploited · CVSS 8.8 High · fixed in 5.15.0-1117.124~20.04.1 : patch Linux kernel soon.
Data as of 26 Oct 2026, 17:16 UTC
- EPSS
- 0.1% chance of exploitation in 30 days – higher than 4% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 5.15.0-1117.124~20.04.1, 5.15.0-1123.132~20.04.1, 5.15.0-1122.131~20.04.1 +66
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 19 Jul 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade to a fixed release listed under Affected software.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 26.04 LTSlinuxpkg:deb/ubuntu/linux?arch=source&distro=resoluteOther threats | Affected
| Fixed in
|
Ubuntu 26.04 LTSlinux-awspkg:deb/ubuntu/linux-aws?arch=source&distro=resoluteOther threats | Affected
| Fixed in
|
Ubuntu 26.04 LTSlinux-azurepkg:deb/ubuntu/linux-azure?arch=source&distro=resoluteOther threats | Affected
| Fixed in
|
Ubuntu 26.04 LTSlinux-azure-fdepkg:deb/ubuntu/linux-azure-fde?arch=source&distro=resoluteOther threats | Affected
| Fixed in
|
Ubuntu 26.04 LTSlinux-gcppkg:deb/ubuntu/linux-gcp?arch=source&distro=resoluteOther threats | Affected
| Fixed in
|
Ubuntu 26.04 LTSlinux-gkepkg:deb/ubuntu/linux-gke?arch=source&distro=resoluteOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
An official patch is available and should be applied promptly to affected linux-aws kernel versions. The vendor advisory confirms that this issue has been resolved in linux-aws kernel versions 7.0.0-28.28~24.04.1 and later. Systems running affected versions should be updated to these or newer patched versions to mitigate the risk.
Description
A vulnerability in the Linux kernel's IPv6 Virtual Tunnel Interface (VTI) implementation was fixed by correcting the use of network namespace references in the vti6_siocdevprivate() function. This flaw caused incorrect tunnel lookups when tunnels were migrated between network namespaces, potentially leading to incorrect packet delivery and privilege escalation. The issue affects multiple linux-aws kernel versions prior to 7.0.0-28.28~24.04.1 and related builds. A patch is available and should be applied to mitigate the risk.
References
- nvd.nist.gov/vuln/detail/CVE-2026-63921 (opens in a new tab)
- git.kernel.org/stable/c/1acfb7d9c6fc7e209ed7789392697e97e03edd33 (opens in a new tab)
- git.kernel.org/stable/c/44d2ff7d2178503b93151140a45dfa2ad49c9906 (opens in a new tab)
- git.kernel.org/stable/c/596f6354c96a891e58c04a09cbfb7b0d1ec00dab (opens in a new tab)
- git.kernel.org/stable/c/853f6ea482dfcd3404bbef458ab4d68364eed838 (opens in a new tab)
- git.kernel.org/stable/c/8b484efd5cb4eeef9021a661e198edc5349dacf6 (opens in a new tab)
- git.kernel.org/stable/c/94ff740a7f9ef5c010784a325dca00cbf228f941 (opens in a new tab)
- git.kernel.org/stable/c/d2236348414bdd6558385f35aa7fdc9bf5634011 (opens in a new tab)
- git.kernel.org/stable/c/df42ac708acc3399bbb6dc5ca16e0540adda7bbf (opens in a new tab)
- ubuntu.com/security/CVE-2026-63921 (opens in a new tab)
- cve.org/CVERecord?id=CVE-2026-63921 (opens in a new tab)
- git.kernel.org/linus/8b484efd5cb4eeef9021a661e198edc5349dacf6 (opens in a new tab)
- ubuntu.com/security/notices/USN-8593-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8603-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8618-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8663-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8664-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8728-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8781-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8728-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-8728-3 (opens in a new tab)
- ubuntu.com/security/notices/USN-8878-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8879-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8877-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8875-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8903-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8905-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8906-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8904-1 (opens in a new tab)