Skip to main content
VulnerabilityPublished Updated

CVE-2026-63998: Linux kernel · ethtool: module: call ethnl_ops_complete() on module flash errors

Affects Linux kernelSource GCVE Database

0
Authoritative record:CVE-2026-63998

Not known to be exploited · CVSS 5.5 Medium · fixed in 7.0.0-28.28~24.04.1 : update Linux kernel when convenient.

Data as of 26 Oct 2026, 12:55 UTC

CVSS 3.1 base score
5.5Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 1% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 7.0.0-28.28~24.04.1, 7.0.0-1016.16~24.04.1, 7.0.0-28.28 +11
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 19 Jul 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
Ubuntu 26.04 LTSlinuxpkg:deb/ubuntu/linux?arch=source&distro=resoluteOther threatsAffected
  • <7.0.0-28.28
Fixed in
  • 7.0.0-28.28
Ubuntu 26.04 LTSlinux-awspkg:deb/ubuntu/linux-aws?arch=source&distro=resoluteOther threatsAffected
  • <7.0.0-1009.9
Fixed in
  • 7.0.0-1009.9
Ubuntu 26.04 LTSlinux-azurepkg:deb/ubuntu/linux-azure?arch=source&distro=resoluteOther threatsAffected
  • <7.0.0-1010.10
Fixed in
  • 7.0.0-1010.10
Ubuntu 26.04 LTSlinux-azure-fdepkg:deb/ubuntu/linux-azure-fde?arch=source&distro=resoluteOther threatsAffected
  • <7.0.0-1009.9
Fixed in
  • 7.0.0-1009.9
Ubuntu 26.04 LTSlinux-gcppkg:deb/ubuntu/linux-gcp?arch=source&distro=resoluteOther threatsAffected
  • <7.0.0-1008.8
Fixed in
  • 7.0.0-1008.8
Ubuntu 26.04 LTSlinux-gkepkg:deb/ubuntu/linux-gke?arch=source&distro=resoluteOther threatsAffected
  • <7.0.0-1003.4
Fixed in
  • 7.0.0-1003.4

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

An official patch is available and should be applied to affected linux-hwe-edge kernel versions. Users should update their systems to the fixed kernel releases as provided by their distribution vendor. No additional mitigation steps are indicated by the vendor advisory.

Description

A vulnerability in the Linux kernel's ethtool module was fixed where the function ethnl_ops_complete() was not called on module flash errors if validate() failed, despite ethnl_ops_begin() being called. This could lead to an inconsistent state in the module operation. The issue affects various versions of the linux-hwe-edge kernel and has a medium severity rating with a CVSS score of 5.5. A patch is available to address this flaw.

References

Community reviews

Loading reviews…