CVE-2026-64007: Linux kernel · netfilter: synproxy: refresh tcphdr after skb_ensure_writable
Affects Linux kernelSource GCVE Database
Not known to be exploited · CVSS 9.8 Critical · fixed in 5.15.0-1116.123~20.04.1 : patch Linux kernel as a priority.
Data as of 28 Oct 2026, 12:12 UTC
- Patch
- Available – fixed in 5.15.0-1116.123~20.04.1, 5.15.0-1122.131~20.04.1, 5.15.0-1121.130~20.04.1 +74
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 19 Jul 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade to a fixed release listed under Affected software.
Patches and advisories
- ubuntu.com/security/notices/USN-8593-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8603-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8618-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8663-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8664-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8728-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8781-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8728-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-8817-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8818-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8818-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-8842-1 (opens in a new tab)
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 26.04 LTSlinuxpkg:deb/ubuntu/linux?arch=source&distro=resoluteOther threats | Affected
| Fixed in
|
Ubuntu 26.04 LTSlinux-awspkg:deb/ubuntu/linux-aws?arch=source&distro=resoluteOther threats | Affected
| Fixed in
|
Ubuntu 26.04 LTSlinux-azurepkg:deb/ubuntu/linux-azure?arch=source&distro=resoluteOther threats | Affected
| Fixed in
|
Ubuntu 26.04 LTSlinux-azure-fdepkg:deb/ubuntu/linux-azure-fde?arch=source&distro=resoluteOther threats | Affected
| Fixed in
|
Ubuntu 26.04 LTSlinux-gcppkg:deb/ubuntu/linux-gcp?arch=source&distro=resoluteOther threats | Affected
| Fixed in
|
Ubuntu 26.04 LTSlinux-gkepkg:deb/ubuntu/linux-gke?arch=source&distro=resoluteOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available and should be applied promptly. The issue is fixed in Linux kernel versions 5.15.0-1116.123~20.04.1, 5.15.0-1122.131~20.04.1, 5.15.0-1121.130~20.04.1, 5.15.0-1118.128~20.04.1, 5.15.0-194.204~20.04.1, and other related 5.15.0 releases. Users and administrators should update to these fixed versions to remediate the vulnerability. No alternative mitigations or workarounds are indicated in the vendor advisory.
Description
CVE-2026-64007 is a critical vulnerability in the Linux kernel's netfilter synproxy implementation. The flaw involves improper handling of the TCP header pointer after skb_ensure_writable() is called, leading to a stale pointer being used for checksum updates. This can cause writes into freed memory or packets with incorrect checksums to be sent. The issue affects multiple Linux kernel versions prior to fixed releases in the 5.15.0 series and some older versions. A patch is available that re-derives the TCP header pointer after skb_ensure_writable() to ensure correct checksum updates.
References
- ubuntu.com/security/CVE-2026-64007 (opens in a new tab)
- cve.org/CVERecord?id=CVE-2026-64007 (opens in a new tab)
- git.kernel.org/linus/92170e6afe927ab2792a3f71902845789c8e31b1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8593-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8603-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8618-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8663-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8664-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8728-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8781-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8728-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-8817-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8818-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8818-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-8842-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8728-3 (opens in a new tab)
- ubuntu.com/security/notices/USN-8818-3 (opens in a new tab)
- ubuntu.com/security/notices/USN-8818-4 (opens in a new tab)
- ubuntu.com/security/notices/USN-8817-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-8849-1 (opens in a new tab)