CVE-2026-64086: Linux kernel · hwmon: (pmbus/adm1266) include PEC byte in pmbus_block_xfer read buffer
Affects Linux kernelSource GCVE Database
Not known to be exploited · CVSS 7.8 High · fixed in 5.15.0-186.196~20.04.1 : patch Linux kernel soon.
Data as of 26 Oct 2026, 14:05 UTC
- EPSS
- 0.1% chance of exploitation in 30 days – higher than 3% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 5.15.0-186.196~20.04.1, 5.15.0-184.194~20.04.1, 5.15.0-1064.66~20.04.1 +17
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 20 Jul 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade to a fixed release listed under Affected software.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 26.04 LTSlinuxpkg:deb/ubuntu/linux@7.0.0-28.28?arch=source&distro=resoluteOther threats | Affected
| Fixed in
|
Ubuntu 26.04 LTSlinux-awspkg:deb/ubuntu/linux-aws@7.0.0-1009.9?arch=source&distro=resoluteOther threats | Affected
| Fixed in– |
Ubuntu 26.04 LTSlinux-azurepkg:deb/ubuntu/linux-azure@7.0.0-1009.9?arch=source&distro=resoluteOther threats | Affected
| Fixed in– |
Ubuntu 26.04 LTSlinux-azure-fdepkg:deb/ubuntu/linux-azure-fde@7.0.0-1008.8?arch=source&distro=resoluteOther threats | Affected
| Fixed in– |
Ubuntu 26.04 LTSlinux-gcppkg:deb/ubuntu/linux-gcp@7.0.0-1008.8?arch=source&distro=resoluteOther threats | Affected
| Fixed in
|
Ubuntu 26.04 LTSlinux-gkepkg:deb/ubuntu/linux-gke@7.0.0-1003.4?arch=source&distro=resoluteOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available and should be applied. Ubuntu has released security updates for affected kernel versions as detailed in their advisory USN-8575-1. Users should update their Linux kernel packages to versions that include this fix. No additional mitigation steps are required beyond applying the official kernel updates.
Description
A buffer overflow vulnerability in the Linux kernel's hwmon subsystem (pmbus/adm1266 driver) was resolved. The vulnerability involved a buffer declared too small to hold the maximum expected data plus a PEC byte, causing out-of-bounds memory access during I2C read operations. This could lead to memory corruption and potentially allow privilege escalation or denial of service. The issue affects specific Linux kernel versions prior to 5.15.0-186.196 and several exact versions listed. A patch is available and has been released by Ubuntu as part of their security updates.
References
- ubuntu.com/security/CVE-2026-64086 (opens in a new tab)
- cve.org/CVERecord?id=CVE-2026-64086 (opens in a new tab)
- git.kernel.org/linus/487566cb1ccdf3756fdd7bf8d875e612ff3169bb (opens in a new tab)
- ubuntu.com/security/notices/USN-8575-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8576-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8593-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8575-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-8576-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-8603-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8575-3 (opens in a new tab)
- ubuntu.com/security/notices/USN-8610-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8618-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8620-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8620-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-8620-3 (opens in a new tab)
- ubuntu.com/security/notices/USN-8620-4 (opens in a new tab)
- ubuntu.com/security/notices/USN-8663-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8664-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8668-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8728-1 (opens in a new tab)