CVE-2026-64089: Linux kernel · batman-adv: tt: fix negative last_changeset_len batadv_piv_tt::last_changeset_len len
Affects Linux kernelSource GCVE Database
Not known to be exploited · CVSS 9.8 Critical · fixed in 5.15.0-1112.119~20.04.1 : patch Linux kernel as a priority.
Data as of 28 Oct 2026, 12:11 UTC
- Patch
- Available – fixed in 5.15.0-1112.119~20.04.1, 5.15.0-1117.126~20.04.1, 5.15.0-1117.126~20.04.2 +74
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 20 Jul 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade to a fixed release listed under Affected software.
Patches and advisories
- ubuntu.com/security/notices/USN-8575-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8576-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8593-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8575-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-8576-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-8603-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8575-3 (opens in a new tab)
- ubuntu.com/security/notices/USN-8610-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8618-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8620-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8620-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-8620-3 (opens in a new tab)
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 26.04 LTSlinuxpkg:deb/ubuntu/linux?arch=source&distro=resoluteOther threats | Affected
| Fixed in
|
Ubuntu 26.04 LTSlinux-awspkg:deb/ubuntu/linux-aws?arch=source&distro=resoluteOther threats | Affected
| Fixed in
|
Ubuntu 26.04 LTSlinux-azurepkg:deb/ubuntu/linux-azure?arch=source&distro=resoluteOther threats | Affected
| Fixed in
|
Ubuntu 26.04 LTSlinux-azure-fdepkg:deb/ubuntu/linux-azure-fde?arch=source&distro=resoluteOther threats | Affected
| Fixed in
|
Ubuntu 26.04 LTSlinux-gcppkg:deb/ubuntu/linux-gcp?arch=source&distro=resoluteOther threats | Affected
| Fixed in
|
Ubuntu 26.04 LTSlinux-gkepkg:deb/ubuntu/linux-gke?arch=source&distro=resoluteOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available and has been released in Linux kernel versions 5.15.0-1106.110~20.04.1 and later. Users and administrators should apply these kernel updates promptly to remediate the vulnerability. No additional mitigation steps are required beyond applying the official fixes.
Description
CVE-2026-64089 is a critical vulnerability in the Linux kernel's batman-adv module related to the handling of the last_changeset_len field. The field was declared as a signed 16-bit integer but was never intended to hold negative values. When values greater than 32767 are assigned, they wrap to negative numbers, causing improper buffer allocation and leaving parts of the buffer uninitialized. This can lead to memory corruption issues. The vulnerability has been fixed in multiple Linux kernel versions starting from 5.15.0-1106.110~20.04.1 and later.
References
- ubuntu.com/security/CVE-2026-64089 (opens in a new tab)
- cve.org/CVERecord?id=CVE-2026-64089 (opens in a new tab)
- git.kernel.org/linus/fc92cdfcb295cefa4344d71a527d61b638b7bfc4 (opens in a new tab)
- ubuntu.com/security/notices/USN-8575-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8576-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8593-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8575-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-8576-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-8603-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8575-3 (opens in a new tab)
- ubuntu.com/security/notices/USN-8610-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8618-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8620-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8620-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-8620-3 (opens in a new tab)
- ubuntu.com/security/notices/USN-8620-4 (opens in a new tab)
- ubuntu.com/security/notices/USN-8663-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8664-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8668-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8728-1 (opens in a new tab)