Skip to main content
VulnerabilityPublished Updated

CVE-2026-64089: Linux kernel · batman-adv: tt: fix negative last_changeset_len

Affects Linux kernelSource GCVE Database

0

Not known to be exploited · CVSS 9.8 Critical · patch available : patch Linux kernel as a priority.

Data as of 26 Oct 2026, 12:55 UTC

CVSS 3.1 base score
9.8Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.5% chance of exploitation in 30 days – higher than 45% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 20 Jul 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

AI-suggested

An official fix is available and should be applied by updating the Linux kernel to the patched versions. Ubuntu has released security notices (USN-8575-1 and USN-8576-1) with updated kernel packages addressing this and other vulnerabilities. After applying updates, a system reboot is required. Due to ABI changes, third-party kernel modules may need recompilation and reinstallation. Users should follow vendor instructions for updating and rebuilding kernel modules as necessary.

Description

A vulnerability in the Linux kernel's batman-adv mesh networking subsystem was resolved. The issue involved a signed 16-bit integer field last_changeset_len that could wrap to a negative value when assigned a value greater than 32767, leading to uninitialized memory usage during buffer population. This flaw was fixed by changing the field to an unsigned 16-bit integer to prevent sign extension errors. The vulnerability affects multiple Linux kernel versions prior to specific 5.15.x updates. A high severity CVSS score of 9.8 indicates critical impact potential. Official patches are available and should be applied. No known exploits are reported in the wild.

References

Community reviews

Loading reviews…