Skip to main content
VulnerabilityPublished Updated

CVE-2026-64361: Linux kernel · hfs/hfsplus: fix u32 overflow in check_and_correct_requested_length

Affects Linux kernelSource GCVE Database

0

Not known to be exploited · CVSS 7.8 High · fixed in 5.15.0-1117.124~20.04.1 : patch Linux kernel soon.

Data as of 26 Oct 2026, 14:05 UTC

CVSS 3.1 base score
7.8High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 2% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 5.15.0-1117.124~20.04.1, 5.15.0-1123.132~20.04.1, 5.15.0-1122.131~20.04.1 +44
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 25 Jul 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
Ubuntu 26.04 LTSlinuxpkg:deb/ubuntu/linux?arch=source&distro=resoluteOther threatsAffected
  • <7.0.0-31.31
Fixed in
  • 7.0.0-31.31
Ubuntu 26.04 LTSlinux-awspkg:deb/ubuntu/linux-aws?arch=source&distro=resoluteOther threatsAffected
  • <7.0.0-1012.12
Fixed in
  • 7.0.0-1012.12
Ubuntu 26.04 LTSlinux-azurepkg:deb/ubuntu/linux-azure?arch=source&distro=resoluteOther threatsAffected
  • <7.0.0-1014.14
Fixed in
  • 7.0.0-1014.14
Ubuntu 26.04 LTSlinux-azure-fdepkg:deb/ubuntu/linux-azure-fde?arch=source&distro=resoluteOther threatsAffected
  • 7.0.0-1003.3 – 7.0.0-1016.16
9 affected builds
Fixed in–
Ubuntu 26.04 LTSlinux-gcppkg:deb/ubuntu/linux-gcp?arch=source&distro=resoluteOther threatsAffected
  • <7.0.0-1011.11
Fixed in
  • 7.0.0-1011.11
Ubuntu 26.04 LTSlinux-gkepkg:deb/ubuntu/linux-gke?arch=source&distro=resoluteOther threatsAffected
  • <7.0.0-1006.7
Fixed in
  • 7.0.0-1006.7

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A vendor-provided patch is available and should be applied to affected Linux kernel versions to remediate this vulnerability. The fix involves updating to patched kernel versions that widen arithmetic operations to 64-bit to prevent overflow. Users should follow the Ubuntu security notice USN-8726-1 and apply the official kernel updates promptly. No additional mitigations are indicated by the vendor advisory.

Description

A vulnerability in the Linux kernel's hfs/hfsplus subsystem allowed a 32-bit unsigned integer overflow in the check_and_correct_requested_length function. This overflow caused incorrect bounds checking, potentially leading to a memory read beyond the intended buffer. The issue was fixed by changing the arithmetic to 64-bit to prevent overflow. The vulnerability has a high severity with a CVSS score of 7.8 and affects multiple Linux kernel versions prior to 7.0.0-31.31 and specific other versions. A patch is available from the vendor.

References

Community reviews

Loading reviews…