CVE-2026-6437: AWS EFS CSI Driver · Argument Injection
Affects AWS EFS CSI DriverSource CVE Database V5
Not known to be exploited · CVSS 6.5 Medium : upgrade to 3.0.1 when convenient.
Data as of 26 Oct 2026, 17:30 UTC
- EPSS
- 0.5% chance of exploitation in 30 days – higher than 46% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 3.0.1
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:NExploitation evidence
Disclosed: evidence found.
CVE published 17 Apr 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade AWS EFS CSI Driver and kubernetes-sigs/aws-efs-csi-driver to 3.0.1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| AmazonAWS EFS CSI Driver | Affected
| Fixed in
|
GitHubkubernetes-sigs/aws-efs-csi-driverpkg:github/kubernetes-sigs/aws-efs-csi-driverOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fix is available by upgrading the AWS EFS CSI Driver to version 3.0.1. Since this is a cloud service component, AWS manages remediation for the cloud-hosted service, but users running the driver themselves should upgrade accordingly. Check the AWS security bulletin at https://aws.amazon.com/security/security-bulletins/2026-016-aws/ for the latest remediation guidance.
Description
CVE-2026-6437 is a vulnerability in the AWS EFS CSI Driver before version 3.0.1 where improper neutralization of argument delimiters allows remote authenticated users with PersistentVolume creation permissions to inject arbitrary mount options via comma injection. This can lead to high confidentiality and integrity impact but does not affect availability. The issue is fixed in version 3.0.1.