Skip to main content
VulnerabilityPublished Updated

CVE-2026-64400: Linux kernel · ksmbd: prevent path traversal bypass by restricting caseless retry

Affects Linux kernelSource CVE Database V5

0

Not known to be exploited · CVSS 8.6 High · fixed in eec1dd2586c4016b7555a5d047db2b3756459fb2 : patch Linux kernel soon.

Data as of 26 Oct 2026, 21:21 UTC

CVSS 3.1 base score
8.6High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.6% chance of exploitation in 30 days – higher than 49% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in eec1dd2586c4016b7555a5d047db2b3756459fb2, cfb5a56c218888f9d74165dff0c282cd0be97983, a1c331d98313380c38f616c8b28b890ec8ef9c28 +5
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 25 Jul 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
LinuxLinuxAffected
  • >=5.15.145 <5.16
  • >=6.1.71 <6.2
  • >=6.3.10 <6.4
Fixed in
  • eec1dd2586c4016b7555a5d047db2b3756459fb2
  • cfb5a56c218888f9d74165dff0c282cd0be97983
  • a1c331d98313380c38f616c8b28b890ec8ef9c28
  • 54bab9ba5a9f156ffa9324fcbe5a356fd0242f95
  • 8c9a4f1327eb71efbf14842e7b8a6d965077eb67
  • 6.4
  • 6.2
  • 5.16
LinuxLinuxAffected
  • =6.4
Fixed in–

AI-suggested

This vulnerability has been fixed in Linux kernel versions 5.16, 6.2, and 6.4 and their respective stable branches. Users and administrators should upgrade affected Linux kernel versions to these fixed releases or later. No additional mitigations are required once the system is updated.

Description

CVE-2026-64400 is a high-severity vulnerability in the Linux kernel's ksmbd component that allows a path traversal bypass. The flaw arises from improper handling of error codes during caseless path lookup retries, enabling write-capable users to create zero-length files or directories outside the intended share boundary. This issue is fixed in Linux kernel versions 5.16, 6.2, and 6.4 and later.

References

Community reviews

Loading reviews…