Skip to main content
VulnerabilityPublished Updated

CVE-2026-64516: Linux kernel · drm/amdgpu/vce1: Fix VCE 1 firmware size and offsets

Affects Linux kernelSource GCVE Database

0

Not known to be exploited · CVSS 8.8 High · fixed in 7.0.0-1010.10 : patch Linux kernel soon.

Data as of 26 Oct 2026, 17:16 UTC

CVSS 3.1 base score
8.8High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 5% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 7.0.0-1010.10, 7.0.0-1009.9, 7.0.0-1008.8 +1
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 27 Jul 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade Linux kernel to 7.0.0-1010.10, 7.0.0-1009.9, 7.0.0-1008.8 or 7.0.0-28.28.

Affected software

ProductAffectedFixed in
linux-hwe-edgeAffected
  • <7.0.0-28.28
  • <7.0.0-1009.9
  • <7.0.0-1010.10
  • <7.0.0-1008.8
Fixed in
  • 7.0.0-28.28
  • 7.0.0-1009.9
  • 7.0.0-1010.10
  • 7.0.0-1008.8

AI-suggested

A patch is available and should be applied promptly. The vendor advisory from Ubuntu confirms fixes are included in Linux kernel versions 7.0.0-28.28~24.04.1 and later, among others. Users should update to the fixed kernel versions listed in the advisory and reboot systems to apply changes. Due to an ABI change, recompilation and reinstallation of third-party kernel modules may be required. No additional mitigation steps are indicated beyond applying the official updates.

Description

A vulnerability in the Linux kernel's drm/amdgpu/vce1 subsystem related to incorrect calculation of firmware size and offsets has been resolved. The issue involved the VCPU buffer object (BO) not properly accounting for firmware offset, potentially leading to out-of-bounds access. The fix ensures correct size calculation and alignment to the 32K TLB size. This vulnerability is addressed in multiple Linux kernel versions with patches available. The CVSS score is 8.8, indicating a high severity vulnerability with potential for privilege escalation and system compromise.

References

Community reviews

Loading reviews…