CVE-2026-64517: Linux kernel · drm/xe/gsc: Fix double-free of managed BO in error path
Affects Linux kernelSource GCVE Database
Not known to be exploited · fixed in 7.0.0-1010.10 : update Linux kernel when convenient.
Data as of 26 Oct 2026, 14:05 UTC
Rated by Threat Radar · No CVSS score from NVD or the CNA
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 10% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 7.0.0-1010.10, 7.0.0-1009.9, 7.0.0-1008.8 +1
Exploitation evidence
Disclosed: evidence found.
CVE published 27 Jul 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade Linux kernel to 7.0.0-1010.10, 7.0.0-1009.9, 7.0.0-1008.8 or 7.0.0-28.28.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| linux-hwe-edge | Affected
| Fixed in
|
AI-suggested
A patch is available and should be applied by updating to the fixed linux-hwe-edge kernel versions as specified by the vendor. After applying the update, a system reboot is required to complete remediation. Due to an ABI change, recompilation and reinstallation of third-party kernel modules may be necessary. Follow the vendor's update instructions carefully to ensure full mitigation.
Description
A double-free vulnerability in the Linux kernel's drm/xe/gsc subsystem was fixed. The issue involved an error path in xe_gsc_init_post_hwconfig() that explicitly freed a buffer object (BO) already managed by devm cleanup, causing a double-free during probe failure. This flaw has been addressed by removing the explicit free and relying on devm to handle cleanup. The vulnerability affects multiple versions of the linux-hwe-edge kernel prior to various 7.0.0 builds. A patch is available and should be applied to prevent potential system compromise.
References
- nvd.nist.gov/vuln/detail/CVE-2026-64517 (opens in a new tab)
- git.kernel.org/stable/c/2c890e71ae26fa32f5a96c3694b71a2c310940e7 (opens in a new tab)
- git.kernel.org/stable/c/7cb975fcd4777e7bad688f66aa0c10c16dd8276b (opens in a new tab)
- git.kernel.org/stable/c/889f70de2b51a877339e1979aab95111b41bed75 (opens in a new tab)
- git.kernel.org/stable/c/d3ded53fab90996e7d94a39049e11962dd066725 (opens in a new tab)
- ubuntu.com/security/CVE-2026-64517 (opens in a new tab)
- cve.org/CVERecord?id=CVE-2026-64517 (opens in a new tab)
- git.kernel.org/linus/d3ded53fab90996e7d94a39049e11962dd066725 (opens in a new tab)
- ubuntu.com/security/notices/USN-8618-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8663-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8664-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8728-1 (opens in a new tab)