CVE-2026-64519: Linux kernel · NFSD: Fix infinite loop in layout state revocation
Affects Linux kernelSource GCVE Database
Not known to be exploited · fixed in 7.0.0-1010.10 : update Linux kernel when convenient.
Data as of 26 Oct 2026, 14:05 UTC
Rated by Threat Radar · No CVSS score from NVD or the CNA
- EPSS
- 0.1% chance of exploitation in 30 days – higher than 6% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 7.0.0-1010.10, 7.0.0-1009.9, 7.0.0-1008.8 +1
Exploitation evidence
Disclosed: evidence found.
CVE published 27 Jul 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade Linux kernel to 7.0.0-1010.10, 7.0.0-1009.9, 7.0.0-1008.8 or 7.0.0-28.28.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| linux-hwe-edge | Affected
| Fixed in
|
AI-suggested
A patch is available and included in Linux kernel versions 7.0.0 and later. Users should update their Linux kernel packages to the fixed versions as provided by their distribution vendor, such as Ubuntu's linux-image packages version 7.0.0-28.28 and later. After updating, a system reboot is required to apply the fix. Due to ABI changes, third-party kernel modules must be recompiled and reinstalled. No additional mitigation steps are necessary beyond applying the official update.
Description
A vulnerability in the Linux kernel's NFS server daemon (NFSD) caused an infinite loop during layout state revocation due to improper handling of state IDs (stids). This flaw was fixed in Linux kernel versions 7.0.0 and later. The issue could cause the revoker to hang indefinitely, impacting system stability. The vulnerability is rated medium severity. Multiple Linux kernel subsystems had security issues fixed in the same update. Users should update to the fixed kernel versions to resolve this and other vulnerabilities.
References
- nvd.nist.gov/vuln/detail/CVE-2026-64519 (opens in a new tab)
- git.kernel.org/stable/c/44e5e4eb3a07bf3e1d931dd9f96f3edcfa376605 (opens in a new tab)
- git.kernel.org/stable/c/4f8ef58c10bfe5f86a643c7c8331b37e69e3dae1 (opens in a new tab)
- git.kernel.org/stable/c/d1fc00ec02e9deb3f8d2bd59caf938c554fbc576 (opens in a new tab)
- git.kernel.org/stable/c/fe59ae27d7346245f5d8d97220f374e63efd28b5 (opens in a new tab)
- ubuntu.com/security/CVE-2026-64519 (opens in a new tab)
- cve.org/CVERecord?id=CVE-2026-64519 (opens in a new tab)
- git.kernel.org/linus/4f8ef58c10bfe5f86a643c7c8331b37e69e3dae1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8618-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8663-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8664-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8728-1 (opens in a new tab)