CVE-2026-64526: Linux kernel · ethtool: tsconfig: fix missing ethnl_ops_complete()
Affects Linux kernelSource GCVE Database
Not known to be exploited · fixed in 7.0.0-1010.10 : update Linux kernel when convenient.
Data as of 26 Oct 2026, 12:55 UTC
Rated by Threat Radar · No CVSS score from NVD or the CNA
- EPSS
- 0.1% chance of exploitation in 30 days – higher than 4% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 7.0.0-1010.10, 7.0.0-1009.9, 7.0.0-1008.8 +1
Exploitation evidence
Disclosed: evidence found.
CVE published 27 Jul 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade Linux kernel to 7.0.0-1010.10, 7.0.0-1009.9, 7.0.0-1008.8 or 7.0.0-28.28.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| linux-hwe-edge | Affected
| Fixed in
|
AI-suggested
A patch is available and should be applied by updating the Linux kernel to versions 7.0.0-28.28 or later as specified in the vendor advisory. After updating, a system reboot is required to apply the changes. Due to an ABI change, all third-party kernel modules must be recompiled and reinstalled. Follow the vendor's update instructions carefully to ensure full remediation.
Description
A vulnerability in the Linux kernel's ethtool tsconfig subsystem was fixed by ensuring proper calls to ethnl_ops_complete() after tsconfig_prepare_data() calls ethnl_ops_begin(). This issue was part of a broader set of Linux kernel security fixes addressing multiple subsystems. The vulnerability could potentially lead to system compromise if exploited. Patches are available and should be applied. The update requires a system reboot and recompilation of third-party kernel modules due to ABI changes.
References
- nvd.nist.gov/vuln/detail/CVE-2026-64526 (opens in a new tab)
- git.kernel.org/stable/c/6386bd772de64e6760306eb91c7e86163af6c22f (opens in a new tab)
- git.kernel.org/stable/c/d02342d9bb4f0ab682f1846a4fbc15dd2955f7e6 (opens in a new tab)
- git.kernel.org/stable/c/d53fe379d1f9a92e8a1bb2556084c8c177ebf8fd (opens in a new tab)
- ubuntu.com/security/CVE-2026-64526 (opens in a new tab)
- cve.org/CVERecord?id=CVE-2026-64526 (opens in a new tab)
- git.kernel.org/linus/6386bd772de64e6760306eb91c7e86163af6c22f (opens in a new tab)
- ubuntu.com/security/notices/USN-8618-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8663-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8664-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8728-1 (opens in a new tab)