Skip to main content
VulnerabilityPublished Updated

CVE-2026-64587: Linux kernel · net: ethernet: arc: emac: quiesce interrupts before requesting IRQ

Affects Linux kernelSource GCVE Database

0

Not known to be exploited · CVSS 7.0 High · fixed in 5.15.0-1112.119~20.04.1 : patch Linux kernel soon.

Data as of 28 Oct 2026, 11:48 UTC

CVSS 3.1 base score
7.0High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 5.15.0-1112.119~20.04.1, 5.15.0-1117.126~20.04.1, 5.15.0-1117.126~20.04.2 +63
CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 6 Aug 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
Ubuntu 24.04 LTSlinuxpkg:deb/ubuntu/linux?arch=source&distro=nobleOther threatsAffected
  • <6.8.0-136.136
Fixed in
  • 6.8.0-136.136
Ubuntu 24.04 LTSlinux-awspkg:deb/ubuntu/linux-aws?arch=source&distro=nobleOther threatsAffected
  • <6.8.0-1061.64
Fixed in
  • 6.8.0-1061.64
Ubuntu 24.04 LTSlinux-aws-6.14pkg:deb/ubuntu/linux-aws-6.14?arch=source&distro=nobleOther threatsAffected
  • 6.14.0-1007.7~24.04.1 – 6.14.0-1018.18~24.04.1
11 affected builds
Fixed in–
Ubuntu 24.04 LTSlinux-aws-6.17pkg:deb/ubuntu/linux-aws-6.17?arch=source&distro=nobleOther threatsAffected
  • 6.17.0-1005.5~24.04.2 – 6.17.0-1020.20~24.04.1
10 affected builds
Fixed in–
Ubuntu 24.04 LTSlinux-azurepkg:deb/ubuntu/linux-azure?arch=source&distro=nobleOther threatsAffected
  • <6.8.0-1063.71
Fixed in
  • 6.8.0-1063.71
Ubuntu 24.04 LTSlinux-azure-6.11pkg:deb/ubuntu/linux-azure-6.11?arch=source&distro=nobleOther threatsAffected
  • 6.11.0-1008.8~24.04.1 – 6.11.0-1018.18~24.04.1
7 affected builds
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available and included in Linux kernel versions 5.15.0-1112.119~20.04.1 and later listed fixed versions. Users should update to these fixed kernel versions to remediate the vulnerability. No additional mitigation steps are required beyond applying the official kernel updates.

Description

CVE-2026-64587 is a high-severity vulnerability in the Linux kernel's ARC EMAC Ethernet driver. It involves improper handling of interrupts during device initialization, where stale interrupt status from firmware or bootloader can cause spurious interrupt delivery and race conditions during device teardown. This issue is resolved by quiescing interrupts before requesting the IRQ, ensuring the device is in a known state and preventing spurious interrupts.

References

Community reviews

Loading reviews…