Skip to main content
VulnerabilityPublished

CVE-2026-64662: statamic cms · Insecure Direct Object Reference

Affects statamic cmsSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 6.5 Medium : upgrade to 6.24.0 or 5.74.1 when convenient.

Data as of 5 Nov 2026, 23:24 UTC

CVSS 3.1 base score
6.5Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 36% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 6.24.0, 5.74.1
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 6 Aug 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Upgrade cms and statamic/cms to 6.24.0 or 5.74.1.

Affected software

ProductAffectedFixed in
statamiccmsAffected
  • >=6.0.0 <6.24.0
Fixed in
  • 6.24.0
statamiccmsAffected
  • <5.74.1
Fixed in
  • 5.74.1
GitHubstatamic/cmspkg:github/statamic/cmsOther threatsAffected
  • <5.74.1
  • <6.24.0
Fixed in
  • 5.74.1
  • 6.24.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade Statamic CMS to version 5.74.1 or later, or 6.24.0 or later, where this authorization bypass vulnerability is fixed. No other mitigation is indicated or required.

Description

Statamic CMS versions prior to 5.74.1 and 6.24.0 contain an authorization bypass vulnerability allowing authenticated Control Panel users to view content from entries they do not have permission to access, including unpublished entries. The vulnerability does not allow modification of data. This issue is fixed in versions 5.74.1 and 6.24.0.

References

Community reviews

Loading reviews…