Skip to main content
VulnerabilityPublished Updated

CVE-2026-6473: PostgreSQL · Integer Overflow or Wraparound

Affects PostgreSQLSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 8.8 High · fixed in 18.4 : patch PostgreSQL soon.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
8.8High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
1.0% chance of exploitation in 30 days – higher than 62% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 18.4, 17.10, 16.14 +2
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 14 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
PostgreSQLAffected
  • >=18 <18.4
Fixed in
  • 18.4
PostgreSQLAffected
  • >=17 <17.10
Fixed in
  • 17.10
PostgreSQLAffected
  • >=16 <16.14
Fixed in
  • 16.14
PostgreSQLAffected
  • >=15 <15.18
Fixed in
  • 15.18
PostgreSQLAffected
  • <14.23
Fixed in
  • 14.23
Postgresqlpostgresql/postgresqlpkg:deb/postgresql/postgresqlOther threatsAffected
  • <14.23
  • <15.18
  • <16.14
  • <17.10
  • <18.4
Fixed in
  • 14.23
  • 15.18
  • 16.14
  • 17.10
  • 18.4

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Red Hat has released official security updates that fix this vulnerability. Users should apply these updates promptly. Additionally, it is recommended to validate the length of data and object sizes on all client APIs and web interfaces, and to block, drop, or truncate oversized string, array, or binary objects before they reach backend SQL queries. Default security features such as SELinux enforcement, ASLR, and NX stack protection also help mitigate the impact.

Description

Integer wraparound in multiple PostgreSQL server features allows an unprivileged database user to cause the server to undersize an allocation and write out-of-bounds. This may execute arbitrary code as the operating system user running the database. In applications that pass gigabyte-scale user inputs to the relevant database functions, the application input provider may achieve a segmentation fault. Versions before PostgreSQL 18.4, 17.10, 16.14, 15.18, and 14.23 are affected.

References

Community reviews

Loading reviews…