CVE-2026-6493: lukevella rallly · Cross-site Scripting
Affects lukevella ralllySource CVE Database V5
Public exploit available · CVSS 5.1 Medium · fixed in 4.8.0 : patch lukevella rallly as a priority.
Data as of 30 Oct 2026, 06:59 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 17% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 4.8.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N/E:PExploitation evidence
Disclosed: evidence found.
CVE published 17 Apr 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: evidence found.
CVSS exploit maturity: proof of concept public
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), CVSS vector, the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| lukevellarallly | Affected
| Fixed in– |
GitHublukevella/ralllypkg:github/lukevella/ralllyOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade lukevella rallly to version 4.8.0 or later, as this version contains the fix for the cross-site scripting vulnerability. No other official remediation or temporary fixes are documented. Patch status is confirmed by the vendor's recommendation to upgrade.
Description
A flaw has been found in lukevella rallly up to 4.7.4. This affects an unknown function of the file apps/web/src/app/[locale]/(auth)/reset-password/components/reset-password-form.tsx of the component Reset Password Handler. Executing a manipulation of the argument redirectTo can lead to cross site scripting. The attack can be executed remotely. The exploit has been published and may be used. Upgrading to version 4.8.0 mitigates this issue. Upgrading the affected component is advised. The vendor was contacted early about this disclosure.
References
- vuldb.com/vuln/358037 (opens in a new tab)
- vuldb.com/vuln/358037/cti (opens in a new tab)
- vuldb.com/submit/787347 (opens in a new tab)
- gist.github.com/TrebledJ/0bd0494a28daaa16abb565b2cef4bd7c (opens in a new tab)
- github.com/lukevella/rallly/pull/2245 (opens in a new tab)
- github.com/lukevella/rallly/releases/tag/v4.8.0 (opens in a new tab)
- github.com/lukevella/rallly/ (opens in a new tab)