Skip to main content
VulnerabilityPublished

CVE-2026-65831: ArcadeData arcadedb · Improper Privilege Management

Affects ArcadeData arcadedbSource CVE Database V5

0
Compare

Mentioned vulnerabilities

Not known to be exploited · CVSS 7.7 High : upgrade to 26.7.1 soon.

Data as of 30 Oct 2026, 20:25 UTC

CVSS 3.1 base score
7.7High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.5% chance of exploitation in 30 days – higher than 48% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 26.7.1
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 15 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade arcadedb and arcadedb-server and arcadedata/arcadedb to 26.7.1.

Affected software

ProductAffectedFixed in
ArcadeDataarcadedbAffected
  • <26.7.1
Fixed in
  • 26.7.1
com.arcadedbarcadedb-serverAffected
  • <26.7.1
Fixed in
  • 26.7.1
GitHubarcadedata/arcadedbpkg:github/arcadedata/arcadedbOther threatsAffected
  • <26.7.1
Fixed in
  • 26.7.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

This vulnerability is fixed in ArcadeDB version 26.7.1. Users should upgrade to version 26.7.1 or later to remediate this issue. No additional mitigations are required once the upgrade is applied.

Description

ArcadeDB is a Multi-Model DBMS. Prior to 26.7.1, a reader-role user can submit POST /api/v1/command/{database} with language: js because PolyglotQueryEngine.command, PolyglotQueryEngine.analyze, and PolyglotQueryEngine.registerFunctions do not enforce database-administrator authorization. GraalPolyglotEngine also permits scripts to bypass the allowedPackages whitelist by reflecting from the bound database object through database.getClass().getClassLoader().loadClass to arbitrary host classes. These cooperating defects allow a read-only database user to read arbitrary host files outside the database scope. Process creation is already blocked, so OS command execution is not confirmed. The issue is distinct from CVE-2026-44221, CVE-2026-54076, and CVE-2026-54077. This issue is fixed in version 26.7.1.

References

Community reviews

Loading reviews…