CVE-2026-65975: pydantic-ai · Incorrect Authorization
Affects pydantic-aiSource CVE Database V5
Not known to be exploited · CVSS 6.5 Medium : upgrade to 2.5.0 or 1.107.1 when convenient.
Data as of 28 Oct 2026, 05:11 UTC
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 25% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.5.0, 1.107.1
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:NExploitation evidence
Disclosed: evidence found.
CVE published 29 Jul 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade pydantic-ai and pydantic-ai-slim to 2.5.0 or 1.107.1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| pydanticpydantic-ai | Affected
| Fixed in
|
| pydanticpydantic-ai | Affected
| Fixed in
|
| pydanticpydantic-ai-slim | Affected
| Fixed in
|
| pydanticpydantic-ai-slim | Affected
| Fixed in
|
PyPIpydantic-aipkg:pypi/pydantic-aiOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade to pydantic-ai versions 1.107.1 or later, or 2.5.0 or later, where this issue is fixed. No other mitigation or temporary workaround is documented. Patch status is not explicitly stated but the fix versions are known; therefore, updating to these versions is recommended.
Description
CVE-2026-65975 is an incorrect authorization vulnerability in pydantic-ai, a Python agent framework for Generative AI applications. In affected versions, certain UI adapters improperly sanitize client-submitted tool calls, allowing a remote client to trigger execution of registered server tools with client-supplied arguments, bypassing model-generated argument checks. This flaw is fixed in versions 1.107.1 and 2.5.0.