CVE-2026-66070: rabbitmq-server · Permissive Cross-domain Policy with Untrusted Domains
Affects rabbitmq-serverSource CVE Database V5
Not known to be exploited · CVSS 7.6 High · fixed in 4.2.6 : patch rabbitmq-server soon.
Data as of 6 Nov 2026, 23:24 UTC
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 31% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 4.2.6, 4.1.13, 4.0.22 +1
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:H/VI:H/VA:N/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 23 Sep 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 6 Nov 2026.
What to do
Upgrade rabbitmq-server to 4.2.6, 4.1.13, 4.0.22 or 3.13.17.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| rabbitmqrabbitmq-server | Affected
| Fixed in
|
| rabbitmqrabbitmq-server | Affected
| Fixed in
|
| rabbitmqrabbitmq-server | Affected
| Fixed in
|
| rabbitmqrabbitmq-server | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
This issue is fixed in rabbitmq-server versions 3.13.17, 4.0.22, 4.1.13, and 4.2.6. Operators should upgrade to these or later versions to remediate the vulnerability. Additionally, avoid configuring the management plugin with the wildcard cors_allow_origins = "*" to prevent this misconfiguration. Patch status is confirmed fixed in the stated versions.
Description
RabbitMQ is a messaging and streaming broker. Prior to versions 3.13.17, 4.0.22, 4.1.13, and 4.2.6, match_origin/1 returned the bare reflected Origin and allowed credentials even when the wildcard "" was configured, so the response echoed the attacker's origin together with Access-Control-Allow-Credentials. The affected code is rabbit_mgmt_cors.erl. When the management plugin is configured with a wildcard CORS origin (cors_allow_origins = ""), the handler reflects the request Origin back in Access-Control-Allow-Origin and also sends Access-Control-Allow-Credentials: true. A malicious web page that a signed-in administrator visits can then use that administrator's cached HTTP Basic credentials to issue authenticated, state-changing requests to the management API. Preconditions include The management plugin is configured with the wildcard cors_allow_origins = "*", which is an explicit operator misconfiguration A target administrator has a cached HTTP Basic-auth session in the browser. This issue is fixed in versions 3.13.17, 4.0.22, 4.1.13, and 4.2.6.