Skip to main content
VulnerabilityPublished

CVE-2026-66072: rabbitmq-server · Uncontrolled Resource Consumption

Affects rabbitmq-serverSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 6.0 Medium · fixed in 4.3.1 : update rabbitmq-server when convenient.

Data as of 6 Nov 2026, 23:24 UTC

CVSS 4.0 base score
6.0Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 41% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 4.3.1, 4.2.6, 4.1.11 +2
CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 23 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 6 Nov 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
rabbitmqrabbitmq-serverAffected
  • >=4.3.0 <4.3.1
Fixed in
  • 4.3.1
rabbitmqrabbitmq-serverAffected
  • >=4.2.0 <4.2.6
Fixed in
  • 4.2.6
rabbitmqrabbitmq-serverAffected
  • >=4.1.0 <4.1.11
Fixed in
  • 4.1.11
rabbitmqrabbitmq-serverAffected
  • >=4.0.0 <4.0.20
Fixed in
  • 4.0.20
rabbitmqrabbitmq-serverAffected
  • >=3.13.0 <3.13.15
Fixed in
  • 3.13.15
GitHubrabbitmq/rabbitmq-serverpkg:github/rabbitmq/rabbitmq-serverOther threatsAffected
  • >=3.13.0 <=3.13.14
  • >=4.0.0 <=4.0.19
  • >=4.1.0 <=4.1.10
  • >=4.2.0 <=4.2.5
  • >=4.3.0 <=4.3.0
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

This issue is fixed in rabbitmq-server versions 3.13.15, 4.0.20, 4.1.11, 4.2.6, and 4.3.1. Users should upgrade to these or later versions to remediate the vulnerability. No additional mitigation steps are indicated by the vendor advisory.

Description

RabbitMQ is a messaging and streaming broker. Prior to versions 3.13.15, 4.0.20, 4.1.11, 4.2.6, and 4.3.1, get_chunk_selector/1 calls binary_to_atom on the raw client-supplied <<"chunk_selector">> property from post-auth subscribe and resolve_offset_spec frames, with no whitelist and no existing guard. An authenticated stream client with read access to any stream can crash the broker node. Preconditions include rabbitmq_stream plugin enabled Authenticated stream-protocol user with read access to at least one stream. This issue is fixed in versions 3.13.15, 4.0.20, 4.1.11, 4.2.6, and 4.3.1.

References

Community reviews

Loading reviews…