Skip to main content
VulnerabilityPublished

CVE-2026-66297: livebook · OS Command Injection

Affects livebookSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 5.0 Medium : upgrade to 0.19.9 or 0.18.7 when convenient.

Data as of 3 Nov 2026, 22:58 UTC

CVSS 4.0 base score
5.0Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
2.4% chance of exploitation in 30 days – higher than 84% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 0.19.9, 0.18.7, 0.19.9-cuda12 +1
CVSS:4.0/AV:N/AC:L/AT:P/PR:H/UI:A/VC:N/VI:N/VA:N/SC:H/SI:H/SA:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 5 Aug 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 3 Nov 2026.

What to do

Upgrade livebook to 0.19.9 or 0.18.7; livebook to 0.19.9-cuda12, 0.19.9, 0.18.7-cuda12 or 0.18.7.

Affected software

ProductAffectedFixed in
livebook-devlivebookAffected
  • >=0.19.0 <0.19.9
Fixed in
  • 0.19.9
livebook-devlivebookAffected
  • >=0.13.0 <0.18.7
Fixed in
  • 0.18.7
livebook-devlivebookAffected
  • >=0.19.0-cuda12 <0.19.9-cuda12
Fixed in
  • 0.19.9-cuda12
livebook-devlivebookAffected
  • >=0.19.0 <0.19.9
Fixed in
  • 0.19.9
livebook-devlivebookAffected
  • >=0.13.0-cuda12 <0.18.7-cuda12
Fixed in
  • 0.18.7-cuda12
livebook-devlivebookAffected
  • >=0.13.0 <0.18.7
Fixed in
  • 0.18.7

CPE configurations (1)

  • cpe:2.3:a:livebook-dev:livebook:*:*:*:*:*:*:*:*

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

If you cannot patch yet, users should carefully review any generated deployment commands before executing them, especially those copied from the Livebook web interface. Restrict privileges to set deployment group environment variables to trusted users only to reduce risk.

Description

CVE-2026-66297 is an OS Command Injection vulnerability in livebook-dev livebook that allows command injection into generated deployment setup commands. The vulnerability arises because deployment group environment variable values are interpolated into Docker and Fly.io setup commands without proper shell escaping. This can lead to execution of arbitrary commands on the machine of the user who runs the generated command. An attacker must have privileges to set deployment group environment variables to exploit this issue. Kubernetes instructions are not affected due to proper escaping in YAML manifests. The vulnerability affects livebook versions from 0.13.0 before 0.18.7 and from 0.19.0 before 0.19.9.

References

Community reviews

Loading reviews…