Skip to main content
VulnerabilityPublished

CVE-2026-66838: elixir-ecto postgrex · SQL Injection

Affects elixir-ecto postgrexSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 5.9 Medium : upgrade to 0.22.4 when convenient.

Data as of 5 Nov 2026, 00:01 UTC

CVSS 4.0 base score
5.9Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 34% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 0.22.4
CVSS:4.0/AV:L/AC:L/AT:P/PR:N/UI:N/VC:H/VI:L/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 7 Aug 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Upgrade elixir-ecto postgrex to 0.22.4.

Affected software

ProductAffectedFixed in
elixir-ectopostgrexAffected
  • >=0.19.3 <0.22.4
Fixed in
  • 0.22.4
elixir-ectopostgrexAffected
  • ≥ 4971a2722fa72f8e1b54a2c403cad4c43916e36d, < e1ecba618ddea4cee2556bd6ad9b6285e05f9d3c
Fixed in–
Hexpostgrexpkg:hex/postgrexOther threatsAffected
  • >=0.19.3 <0.22.4
Fixed in
  • 0.22.4

CPE configurations (1)

  • cpe:2.3:a:elixir-ecto:postgrex:*:*:*:*:*:*:*:*

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

If you cannot patch yet, avoid passing untrusted input to the :comment option in Postgrex.stream/4 or Ecto.Repo.stream/2 to prevent injection.

Description

CVE-2026-66838 is a medium severity SQL Injection vulnerability in the elixir-ecto postgrex library. It arises from improper neutralization of special elements in the :comment option of Postgrex.stream/4, allowing an attacker who can control this value to inject SQL clauses within the streamed statement. The injection is limited to the streamed statement and cannot chain further commands. This affects postgrex versions from 0.19.3 up to but not including 0.22.4.

References

Community reviews

Loading reviews…