Skip to main content
VulnerabilityPublished Updated

CVE-2026-67211: Apache OpenNLP · Excessive Memory Allocation

Affects Apache OpenNLPSource CVE Database V5

0

Not known to be exploited · CVSS 7.5 High : upgrade to 3.0.0-M6 soon.

Data as of 26 Oct 2026, 17:16 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.7% chance of exploitation in 30 days – higher than 54% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 3.0.0-M6
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 11 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade Apache to 3.0.0-M6.

Affected software

ProductAffectedFixed in
Apache Software FoundationApache OpenNLPAffected
  • >=3.0.0-M4 <3.0.0-M6
Fixed in
  • 3.0.0-M6
MavenApache Software Foundation/org.apache.opennlp:opennlp-symspellpkg:maven/Apache Software Foundation/org.apache.opennlp:opennlp-symspellOther threatsAffected
  • >=3.0.0-M4 <3.0.0-M6
Fixed in
  • 3.0.0-M6

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fixed version, Apache OpenNLP 3.0.0-M6, is available and users are strongly advised to upgrade. The fix enforces an upper bound on the size fields in SymSpell model files to prevent excessive memory allocation. Users who cannot upgrade immediately should treat all SymSpell .bin model files as untrusted input unless their provenance is verified and avoid loading models from untrusted sources without integrity checks. The OPENNLP_MAX_ENTRIES system property can be used to adjust the upper bound if larger dictionaries are legitimately required.

Description

CVE-2026-67211 is a high-severity denial of service vulnerability in Apache OpenNLP versions 3.0.0-M4 and 3.0.0-M5. It arises from unbounded memory allocation when deserializing SymSpell model files with attacker-controlled size fields, leading to OutOfMemoryError and process crashes. The issue affects the SymSpellModelSerializer.create() method and all code paths that load SymSpell models from untrusted sources. The vulnerability is fixed in version 3.0.0-M6 by enforcing an upper bound on the size fields to prevent excessive memory allocation.

References

Community reviews

Loading reviews…