Skip to main content
VulnerabilityPublished

CVE-2026-67220: rabbitmq-server · Uncontrolled Resource Consumption

Affects rabbitmq-serverSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 6.0 Medium · fixed in 4.2.6 : update rabbitmq-server when convenient.

Data as of 6 Nov 2026, 23:24 UTC

CVSS 4.0 base score
6.0Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 24% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 4.2.6, 4.1.11, 4.0.20 +1
CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 23 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 6 Nov 2026.

What to do

Upgrade rabbitmq-server and rabbitmq/rabbitmq-server to 4.2.6, 4.1.11, 4.0.20 or 3.13.15.

Affected software

ProductAffectedFixed in
rabbitmqrabbitmq-serverAffected
  • >=4.2.0 <4.2.6
Fixed in
  • 4.2.6
rabbitmqrabbitmq-serverAffected
  • >=4.1.0 <4.1.11
Fixed in
  • 4.1.11
rabbitmqrabbitmq-serverAffected
  • >=4.0.0 <4.0.20
Fixed in
  • 4.0.20
rabbitmqrabbitmq-serverAffected
  • >=3.13.0 <3.13.15
Fixed in
  • 3.13.15
GitHubrabbitmq/rabbitmq-serverpkg:github/rabbitmq/rabbitmq-serverOther threatsAffected
  • <3.13.15 >=3.13.0
  • <4.0.20 >=4.0.0
  • <4.1.11 >=4.1.0
  • <4.2.6 >=4.2.0
Fixed in
  • 3.13.15
  • 4.0.20
  • 4.1.11
  • 4.2.6

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

This vulnerability is fixed in rabbitmq-server versions 3.13.15, 4.0.20, 4.1.11, 4.2.6, and 4.3.0. Users should upgrade to these or later versions to remediate the issue. No additional mitigation steps are indicated by the vendor advisory.

Description

RabbitMQ is a messaging and streaming broker. Prior to versions 3.13.15, 4.0.20, 4.1.11, 4.2.6, 4.3.0, When a binding is created on an x-jms-topic exchange, add_binding/3 reads the rjms_erlang_selector argument and passes it through erl_scan:string/1 then erl_parse:parse_term/1. erl_scan:string/1 interns every atom literal it tokenizes. validate_binding/2 is a no-op (-> ok.), there is no length cap, and the surrounding try/catch cannot reclaim atoms. The Java JMS client compiles selectors client-side, but the server does not enforce this , a raw AMQP client can send arbitrary selector strings. An authenticated low-privilege AMQP user confined to one vhost can crash the entire broker node (cross-tenant DoS) in <100 bind calls. Preconditions include rabbitmq_jms_topic_exchange plugin enabled (bundled; required for any JMS deployment) Authenticated AMQP user with read on an x-jms-topic exchange + write on a queue (or configure to declare both). This issue is fixed in versions 3.13.15, 4.0.20, 4.1.11, 4.2.6, 4.3.0.

References

Community reviews

Loading reviews…