Skip to main content
VulnerabilityPublished Updated

CVE-2026-67231: rabbitmq-server · Improper Certificate Validation

Affects rabbitmq-serverSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 9.1 Critical · fixed in 4.2.6 : patch rabbitmq-server as a priority.

Data as of 6 Nov 2026, 23:24 UTC

CVSS 4.0 base score
9.1Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 13% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 4.2.6, 4.1.11, 4.0.20 +1
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 23 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 7 Nov 2026.

What to do

Upgrade rabbitmq-server and rabbitmq/rabbitmq-server to 4.2.6, 4.1.11, 4.0.20 or 3.13.15.

Affected software

ProductAffectedFixed in
rabbitmqrabbitmq-serverAffected
  • >=4.2.0 <4.2.6
Fixed in
  • 4.2.6
rabbitmqrabbitmq-serverAffected
  • >=4.1.0 <4.1.11
Fixed in
  • 4.1.11
rabbitmqrabbitmq-serverAffected
  • >=4.0.0 <4.0.20
Fixed in
  • 4.0.20
rabbitmqrabbitmq-serverAffected
  • >=3.13.0 <3.13.15
Fixed in
  • 3.13.15
GitHubrabbitmq/rabbitmq-serverpkg:github/rabbitmq/rabbitmq-serverOther threatsAffected
  • >=3.13.0 <3.13.15
  • >=4.0.0 <4.0.20
  • >=4.1.0 <4.1.11
  • >=4.2.0 <4.2.6
Fixed in
  • 3.13.15
  • 4.0.20
  • 4.1.11
  • 4.2.6

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade rabbitmq-server to version 3.13.15, 4.0.20, 4.1.11, 4.2.6, or later where this issue is fixed. The vendor advisory confirms these versions contain the official fix. If upgrading is not immediately possible, consider disabling the trust-store plugin or avoiding its use as the TLS verify_fun until patched.

Description

RabbitMQ is a messaging and streaming broker. Prior to versions 3.13.15, 4.0.20, 4.1.11, 4.2.6, and 4.3.0, The trust-store plugin installs a verify_fun that overrides {bad_cert, unknown_ca} / {bad_cert, selfsigned_peer} when the presented cert "matches" a whitelisted one. The match key is extract_issuer_id/1 → public_key:pkix_issuer_id/2 → {IssuerName, SerialNumber} , both fields are taken verbatim from the presented certificate body and contain no public-key, SKI, fingerprint or signature material. is_whitelisted/1 is a pure ets:member lookup; the stored full DER is used only for list/0 display and is never compared against the presented cert. cacerts is [], so the whitelisted cert is never used as a trust anchor for path validation either. TLS client-authentication bypass: an attacker who knows the issuer DN + serial of any whitelisted certificate can connect with a forged self-signed cert. Preconditions include rabbitmq_trust_store plugin enabled and used as the TLS verify_fun Attacker knows or can guess the {Issuer, Serial} of at least one whitelisted cert (non-secret; exposed via CLI/logs/any cert copy). This issue is fixed in versions 3.13.15, 4.0.20, 4.1.11, 4.2.6, and 4.3.0.

References

Community reviews

Loading reviews…