Skip to main content
VulnerabilityPublished

CVE-2026-67232: rabbitmq-server · Data Amplification

Affects rabbitmq-serverSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 8.2 High · fixed in 4.2.6 : patch rabbitmq-server soon.

Data as of 6 Nov 2026, 23:24 UTC

CVSS 4.0 base score
8.2High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 33% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 4.2.6, 4.1.11, 4.0.20 +1
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 23 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 6 Nov 2026.

What to do

Upgrade rabbitmq-server and rabbitmq/rabbitmq-server to 4.2.6, 4.1.11, 4.0.20 or 3.13.15.

Affected software

ProductAffectedFixed in
rabbitmqrabbitmq-serverAffected
  • >=4.2.0 <4.2.6
Fixed in
  • 4.2.6
rabbitmqrabbitmq-serverAffected
  • >=4.1.0 <4.1.11
Fixed in
  • 4.1.11
rabbitmqrabbitmq-serverAffected
  • >=4.0.0 <4.0.20
Fixed in
  • 4.0.20
rabbitmqrabbitmq-serverAffected
  • >=3.13.0 <3.13.15
Fixed in
  • 3.13.15
GitHubrabbitmq/rabbitmq-serverpkg:github/rabbitmq/rabbitmq-serverOther threatsAffected
  • >=3.13.0 <3.13.15
  • >=4.0.0 <4.0.20
  • >=4.1.0 <4.1.11
  • >=4.2.0 <4.2.6
Fixed in
  • 3.13.15
  • 4.0.20
  • 4.1.11
  • 4.2.6

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade rabbitmq-server to version 3.13.15, 4.0.20, 4.1.11, 4.2.6, or later where this issue is fixed. If upgrading is not immediately possible, consider disabling the rabbitmq_web_mqtt plugin to prevent exposure. No other mitigations are specified in the advisory.

Description

RabbitMQ is a messaging and streaming broker. Prior to versions 3.13.15, 4.0.20, 4.1.11, 4.2.6, and 4.3.0, The cowboy WebSocket options at line 117 set compress => true, enabling RFC 7692 permessage-deflate negotiation. The handler does not set max_frame_size, so cowboy's default of infinity applies. cowlib's cow_ws:parse_payload/9 calls zlib:inflate/2 on the compressed payload with no output-size limit. An attacker can negotiate permessage-deflate during the WebSocket upgrade and send a frame containing a zlib bomb (e.g. 50 KB → 5 GB). Decompression occurs in the connection process before websocket_handle/2 ever sees the MQTT bytes. An unauthenticated attacker can crash a RabbitMQ node running the Web-MQTT plugin by sending a single highly-compressed WebSocket frame (a few KB on the wire) that inflates to gigabytes in memory. The cowboy WebSocket handler decompresses the entire frame before the MQTT CONNECT packet is processed, so no credentials are required. Preconditions include rabbitmq_web_mqtt plugin enabled (not default, but common for browser clients) Network reachability to port 15675/15676 No authentication required. This issue is fixed in versions 3.13.15, 4.0.20, 4.1.11, 4.2.6, and 4.3.0.

References

Community reviews

Loading reviews…