CVE-2026-67341: ArcadeData arcadedb · Incorrect Authorization
Affects ArcadeData arcadedbSource CVE Database V5
Not known to be exploited · CVSS 9.3 Critical : upgrade to 26.7.2 as a priority.
Data as of 31 Oct 2026, 08:20 UTC
- EPSS
- 0.5% chance of exploitation in 30 days – higher than 45% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 26.7.2
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 1 Aug 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade arcadedb and arcadedata/arcadedb to 26.7.2.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| ArcadeDataarcadedb | Affected
| Fixed in
|
GitHubarcadedata/arcadedbpkg:github/arcadedata/arcadedbOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
If you cannot patch yet, restrict database access to trusted users only and monitor for unauthorized DEFINE FUNCTION statements. Avoid granting unnecessary database access privileges to untrusted users.
Description
ArcadeDB versions before 26.7.2 fail to enforce scripting authorization checks on the SQL DEFINE FUNCTION statement with LANGUAGE js. Attackers with database access can execute arbitrary JavaScript code by submitting DEFINE FUNCTION statements, bypassing security controls intended to restrict scripting to administrators.