Skip to main content
VulnerabilityPublished

CVE-2026-6736: GitHub Enterprise Server · Missing Authentication

Affects GitHub Enterprise ServerSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 6.3 Medium · fixed in 3.20.2 : update GitHub Enterprise Server when convenient.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 4.0 base score
6.3Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 18% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 3.20.2
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 7 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
GitHubEnterprise ServerAffected
  • >=3.16.0 <3.16.18
  • >=3.17.0 <3.17.15
  • >=3.18.0 <3.18.9
  • >=3.19.0 <3.19.6
  • >=3.20.0 <3.20.2
Fixed in–

AI-suggested

This vulnerability is fixed in GitHub Enterprise Server versions 3.20.2, 3.19.6, 3.18.9, 3.17.15, and 3.16.18. Users should upgrade to one of these fixed versions or later to remediate the issue. Since this is not a cloud service, patching the affected server instances is required. Patch status is confirmed by the vendor advisory information embedded in the description.

Description

CVE-2026-6736 is an authentication bypass vulnerability in GitHub Enterprise Server versions prior to 3.21. It allows an unauthenticated attacker to create a local user account despite external identity provider enforcement. The vulnerability occurs because the signup endpoint does not properly enforce authentication restrictions when external authentication is enabled. The attacker can establish a session with default base permissions on the instance. Exploitation requires network access to a vulnerable GitHub Enterprise Server instance configured with an external authentication provider. The issue was fixed in versions 3.20.2, 3.19.

References

Community reviews

Loading reviews…